Results 1 to 9 of 9

front end problem

This is a discussion on front end problem within the General Help forums, part of the LSx Technical Help Section category; so everytime i hit the brakes, go over a bump or even give my car gas from a stop there ...

  1. #1
    Junior Member
    Join Date
    Jul 2006
    Location
    chicago, il
    Posts
    46

    red
    2000 Camaro SS Conv.

    front end problem

    so everytime i hit the brakes, go over a bump or even give my car gas from a stop there is a creeking noise coming from the front end. if i go to the front of the car and push down on the front end by the wheels there is a real bad creeking noise, like and old matress being bounced on sound. what could this possibly be and could it be something covered by the warrenty?

  2. #2
    Lurking MechanicalMehem's Avatar
    Join Date
    Feb 2006
    Location
    Oklahoma
    Age
    36
    Posts
    255

    white/black
    2000 z28

    creaking, could be.... worn struts, upper strut mounts, ball joints, a-arm bushings.. basically you need someone to jounce the suspension with you under the car, reach around and touch different parts of the suspension, at some point you will feel like a roughness or vibration on which ever part is causing the noise, now, mind you, just because you felt it in the control arm, it could be another part that is bolted to it that is causing the sound/vibration transfer. Hope this helps!
    --Justin

  3. #3
    Junior Member
    Join Date
    Jul 2006
    Location
    chicago, il
    Posts
    46

    red
    2000 Camaro SS Conv.

    yea that helps. i forgot to mention though that it doesn't always make the noises. today i left the house this morning and it was fine. after driving for about 30 minutes i started hearing the noise. i got back to my house and when i push down right by the tires it would make the noise. i sat at my house for about 20 minutes and then came back out and it didn't make the noise. i picked up a buddy and drove around for 20 minutes and nothing. then i got back to my house and when we got out of the car it was making the noise again, so i don't know.

  4. #4
    Ricekiller z28punk's Avatar
    Join Date
    Nov 2006
    Location
    Maple Grove, MN
    Age
    29
    Posts
    509

    Pewter
    2002 Camaro Z28

    check the sway bar bushings. they make a creeking noise when they get dry. they can get as bad as making popping noises too.

    if u dont want to replace them, put some brake caliper grease on them and that might fix the sounds.
    Last edited by z28punk; 06-17-2007 at 09:46 PM.

  5. #5
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    I have poly bushings on my front and rear upgraded sway bars, and they creak every bump that I go over.

    SteveC

  6. #6
    Junior Member
    Join Date
    Jul 2006
    Location
    chicago, il
    Posts
    46

    red
    2000 Camaro SS Conv.

    yea, then that sounds like thats the most likely thing cause it goes in and out. some days there will be nothing then the next day it will go in and out. i'll check that out, thanks.

  7. #7
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    i second that. proly just worn or dry sway bar bushings

  8. #8
    Junior Member ssxcytmnt's Avatar
    Join Date
    Sep 2005
    Location
    Ft Worth
    Age
    52
    Posts
    32

    Red
    2000 Camaro SS 300K

    I had the same problem, I went to auto zone and bought some grease from the suspension parts area and then took down my sway bar and end links and greased them up.. It took care of the problem..I suggest using as much grease as possiable with out over doing it.. Basicly , dont be cheap putting it on. The package comes with 2 or 3 tubes of grease for the bushings.. Hope it helps...

  9. #9
    Junior Member
    Join Date
    Jul 2006
    Location
    chicago, il
    Posts
    46

    red
    2000 Camaro SS Conv.

    alright, thanks for the help guys. i just got back from vacation so i'm gonna run to autozone this weekend.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. another front turn signal problem
    By hiredgun58 in forum Firebird / WS6
    Replies: 3
    Last Post: 03-28-2015, 01:29 PM
  2. 2002 Camaro SS Passenger side front fender and front bumper
    By Vexzer in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-21-2012, 06:56 AM
  3. Help: UMI front sway bar fitment problem
    By xmarkx in forum Suspension and Handling
    Replies: 11
    Last Post: 01-09-2011, 06:59 PM
  4. Question: front end problem...
    By Kaotic_ws6 in forum Firebird / WS6
    Replies: 22
    Last Post: 02-10-2009, 10:23 AM
  5. front end problem
    By malibumaniac in forum Drivetrain
    Replies: 2
    Last Post: 09-22-2005, 03:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •