Page 1 of 2 12 LastLast
Results 1 to 20 of 36

Freaking Slp Lid Doesn't Lock!!!!

This is a discussion on Freaking Slp Lid Doesn't Lock!!!! within the General Help forums, part of the LSx Technical Help Section category; I bought an SLP lid for my trans am and one of the latches doesn't close? Have any of you ...

  1. #1
    Member
    Join Date
    Jan 2007
    Location
    EL PASO TX.
    Posts
    163

    NAVY BLUE METALLIC
    02' WS6 TRANS AM

    Freaking Slp Lid Doesn't Lock!!!!

    I bought an SLP lid for my trans am and one of the latches doesn't close? Have any of you had this same problem? How or what can i do to keep the damn thing closed?

  2. #2
    Member
    Join Date
    Jan 2006
    Location
    Harrisburg
    Age
    33
    Posts
    364

    Black
    2000 TA

    i thought the same thing when i first got mine but then i played with it alittle more and got it to fit nice and snug. Is the lip on the front on the inside or outside of the bottom mount. I ended up making mine work on the inside.

  3. #3
    Member
    Join Date
    Jan 2007
    Location
    EL PASO TX.
    Posts
    163

    NAVY BLUE METALLIC
    02' WS6 TRANS AM

    Quote Originally Posted by texinteg View Post
    i thought the same thing when i first got mine but then i played with it alittle more and got it to fit nice and snug. Is the lip on the front on the inside or outside of the bottom mount. I ended up making mine work on the inside.
    No i think that the slp lid the upper is over the bottom part. That's how i have it on right now. The right latch closes fine, it's the left one that always keeps on opening up!

    if you got any pics it would help alot man! thanks!

  4. #4
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    30
    Posts
    273

    pewter
    01 ws6

    Quote Originally Posted by texinteg View Post
    i thought the same thing when i first got mine but then i played with it alittle more and got it to fit nice and snug. Is the lip on the front on the inside or outside of the bottom mount. I ended up making mine work on the inside.
    <<<<<<<<<<<<<<<<<<<
    yep

  5. #5
    Member
    Join Date
    Jan 2006
    Location
    Harrisburg
    Age
    33
    Posts
    364

    Black
    2000 TA

    Dont have any pics but mine definately fit better when I tucked the upper front into the lower bottom.

  6. #6
    LoudMouth SStriker's Avatar
    Join Date
    Jul 2006
    Location
    Westminster/Sykesville, Maryland
    Age
    27
    Posts
    512

    Red
    2000 Trans Am

    mine fit funny at first. I also had to just play with it. One issue was my Fernco coupler, it wasnt allowing it to sit all the way down, i just had to loosen it and twist the lid some to fix snug.

  7. #7
    Member sirenformula350's Avatar
    Join Date
    Jan 2006
    Location
    Chicago
    Age
    32
    Posts
    597

    Silver
    1998 Trans Am

    I had the same problem for the longest time and like everyone else said make sure the front part of the lid is sitting behind the lip of the box. If you really need a pic I might be able to get one up at the end of the weekend. Unless anyone else beats me to it.

  8. #8
    Bmike Dillard99's Avatar
    Join Date
    Dec 2006
    Location
    Charlotte,NorthCarolina
    Posts
    355

    Metalic Navy Blue
    2001 Camaro Z28

    yep mine is to the right side locks up but the left side keeps poping off

  9. #9
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    Quote Originally Posted by SMOKIN WS6 View Post
    No i think that the slp lid the upper is over the bottom part. That's how i have it on right now. The right latch closes fine, it's the left one that always keeps on opening up!

    if you got any pics it would help alot man! thanks!
    You answered your own question...the lids lip goes inside of the lower air assemblys lip.

  10. #10
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    29
    Posts
    1,316

    Black
    1999 Trans Am M6

    I had the same problem, I ended up screwing around with the smooth bellows so the lid could slide back a little bit.

  11. #11
    Member waldo's Avatar
    Join Date
    Apr 2007
    Location
    Wisconsin
    Posts
    617

    Machine Silver
    05 Corvette

    Quote Originally Posted by GottaHaveLS1 View Post
    I had the same problem, I ended up screwing around with the smooth bellows so the lid could slide back a little bit.
    Had the same problem. Just be patient and keep adjusting and reclosing it, it will settle in and stay closed…… eventually.

  12. #12
    ArtistFormerlyKnownAsMac Silver Streak's Avatar
    Join Date
    Apr 2006
    Location
    Indianapolis, IN
    Posts
    4,845

    All Black
    83, 87, 02 All WS6 T/As

    My Dr side always kept coming unlatched... till I said fuck the K&N (cleaned it 3 times in less than 2 months.. and went back to the paper filter.. and it sealed nice and tight and no probs since.
    -Geno
    1983 Black WS6 "WindCharger"
    1987 Black WS6 "WS87"
    2002 Black WS6 "Silver Streak"
    Sold the other four f-bodies

  13. #13
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    47
    Posts
    416

    navy blue metallic
    2001 trans am

    same thing here,mine was a little hard to get on but thats what you want to get a snug fit. Ill take a pick and post it

  14. #14
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    47
    Posts
    416

    navy blue metallic
    2001 trans am


  15. #15
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Lid is supposed to be TOP INSIDE LOWER LIP on all lids no matter who made them.
    Shove that sucker all the way back & it'll stay latched.....that is all

  16. #16
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    47
    Posts
    416

    navy blue metallic
    2001 trans am

    my core support is tweeked from a mild front end collison so my lid doesnt fit PERFECT bit its tight ans sealed good due to the filter being in there

  17. #17
    Member
    Join Date
    Jan 2007
    Location
    EL PASO TX.
    Posts
    163

    NAVY BLUE METALLIC
    02' WS6 TRANS AM

    Quote Originally Posted by GottaHaveLS1 View Post
    I had the same problem, I ended up screwing around with the smooth bellows so the lid could slide back a little bit.
    I have the exact same problem... i fell for the smooth bellows crap so now i have less flexibility to play around with the lid since it's way tougher than the accordion style one. i guess i just gotta play around with it some more!

    so the top part of my lid goes inside not outside to fit better right?

  18. #18
    Member
    Join Date
    Jan 2007
    Location
    EL PASO TX.
    Posts
    163

    NAVY BLUE METALLIC
    02' WS6 TRANS AM

    I HATE THIS LID IT JUST WON'T STAY CLOSED!!!!

  19. #19
    ArtistFormerlyKnownAsMac Silver Streak's Avatar
    Join Date
    Apr 2006
    Location
    Indianapolis, IN
    Posts
    4,845

    All Black
    83, 87, 02 All WS6 T/As

    You could always get some rubber weatherstripping from like Lowes or something to put under the lid.. so It seals tighter.. making the clip stay latched... thats what I was going to do if the paper filter didn't make it fit right.

  20. #20
    Member
    Join Date
    Jan 2007
    Location
    EL PASO TX.
    Posts
    163

    NAVY BLUE METALLIC
    02' WS6 TRANS AM

    I think it closes fine.... it's just that the stupid clip seems like it's not long enought to latch on to the lid. Guess i just need to play with it some more!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLP lid...tried for a day and took it back off.
    By stanger88 in forum External Engine
    Replies: 31
    Last Post: 05-26-2007, 09:40 AM
  2. slp blow -out update list
    By Stealthperf.com in forum Sales and Group Purchases from our Great Sponsors!
    Replies: 0
    Last Post: 04-08-2006, 05:10 PM
  3. Super Close-out Sale on SLP Products
    By Stealthperf.com in forum Sales and Group Purchases from our Great Sponsors!
    Replies: 21
    Last Post: 03-24-2006, 04:52 PM
  4. SLP Air-Box lid wont fit?
    By GlowStickgl in forum General Help
    Replies: 8
    Last Post: 01-11-2006, 10:41 PM
  5. Cat back is next....What brand?
    By timmyvws6 in forum External Engine
    Replies: 27
    Last Post: 01-06-2006, 12:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •