Results 1 to 7 of 7

Flowmaster Muffler

This is a discussion on Flowmaster Muffler within the General Help forums, part of the LSx Technical Help Section category; A buddy of mine has a Camaro with the LS1 engine. He put a flowmaster muffler in place of the ...

  1. #1
    Member speedracer25f's Avatar
    Join Date
    Nov 2007
    Location
    Bethlehem, Pa
    Age
    43
    Posts
    202

    Midnight Blue
    1998 Trans Am

    Flowmaster Muffler

    A buddy of mine has a Camaro with the LS1 engine. He put a flowmaster muffler in place of the stock muffler and now it throws o2 sensor codes. Anyone else have this problem?

  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Never heard of that..

  3. #3
    Junior Member
    Join Date
    Sep 2005
    Location
    Redding
    Age
    32
    Posts
    6

    Bright Red
    02 Ws6

    Me neither. I would think its more of a coincedence (sp). Its probably the 02's or the cats. A auto shop should be able to tell you.

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    They arent related. What codes is he throwing? Why did he go with a slowmaster?
    J
    2001 SS, Its not the car its the Driver that matters....

  5. #5
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    ^^^^

  6. #6
    Member Since 1998 Mecinoid's Avatar
    Join Date
    May 2007
    Location
    Livermore, Ca.
    Posts
    498
    '98,'00 Bird '03, 14 Vets

    Catback or just muffler. Just muffler nah. If catback maybe lose connection on O2 or overheated the pipe while welding closeby. Only thing I can think of. I say just that the O2 is going bad. Did you install headers with that system? Y-pipe? Exhaust leak up front somewhere or damage from lift etc.... ???? Those are just some things I'd check.... But, most like just a bad O2.

  7. #7
    Member jag42420's Avatar
    Join Date
    Aug 2006
    Location
    Kentucky
    Age
    43
    Posts
    525

    Silver
    2002 WS6 Trans Am

    What are the codes (front or rear o2)? There is most likely either a leak, damage to the cat, or a bad sensor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Flowmaster Muffler
    By 2002ssslp in forum Camaro / SS
    Replies: 14
    Last Post: 03-08-2012, 06:00 PM
  2. Used Flowmaster Muffler from 98-02 Fbody
    By madmatt in forum Parts For Sale / Trade
    Replies: 12
    Last Post: 09-28-2007, 01:24 PM
  3. Flowmaster Muffler? WHICH ONE?!!?
    By SteelmanLS1 in forum Firebird / WS6
    Replies: 25
    Last Post: 05-26-2007, 05:35 AM
  4. Flowmaster Muffler
    By homerunhtr21 in forum Parts For Sale / Trade
    Replies: 8
    Last Post: 03-26-2007, 07:58 PM
  5. flowmaster muffler gone bad
    By adham in forum External Engine
    Replies: 4
    Last Post: 01-21-2006, 11:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •