Results 1 to 5 of 5

Fixing air conditioning system.

This is a discussion on Fixing air conditioning system. within the General Help forums, part of the LSx Technical Help Section category; I have been putting it off but have decided to fix the a/c in my truck. It is a 95 ...

  1. #1
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Fixing air conditioning system.

    I have been putting it off but have decided to fix the a/c in my truck. It is a 95 Tahoe. I know there was a leak at one time. There was dye put into the system but I can't find a leak. The a/c compressor doesnt turn on. I can hear the relay clicking when removing and reinstalling. I am pretty sure that the low refrigerant is keeping the compressor from coming on. What do I have to do to get the compressor on? I will fill the system with more dye and oil to try and locate the leak.

  2. #2
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    you're on the right track, need refrigerant to be in there to kick the compressor on. if there is dye in there like you say you need a black light to see it good as it should be flourescent. also there is prolly a leak like you say and you cant see the dye then look for dust build up around joint locations and around the codensor as it is susceptible to rock damage. the dust build up will be from the system oil

  3. #3
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    also just on a side note, your in NY and worried about a/c?!?!?!?!?!




  4. #4
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Yeah I have used a blacklight to look for a leak. Couldnt find any. Could possibly be behind the tranny cooler. I will look for dust buildup. And yes I need a/c. It does get hot and humid here in summer on occasion.

  5. #5
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    haha i just bustin your balls man! it in the 90s here with 85% humidity, just getting warmed up... yeah dust build up is a good way to find a leak cuz of system oil. also the back of the compressor has a blowoff valve if there is a build up of system pressure it pops. mite check that, if that is the source then usually the orifice is clogged with most likely metal from a shelling compressor

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Air conditioning not working
    By pdr-79 in forum General Help
    Replies: 9
    Last Post: 10-20-2015, 04:20 AM
  2. Help: Air Conditioning Took A Crap!
    By 90ARAPAJ in forum Firebird / WS6
    Replies: 2
    Last Post: 05-22-2012, 10:05 AM
  3. SS Air Conditioning - Need Help
    By 99WickedSS in forum General Help
    Replies: 4
    Last Post: 06-06-2011, 08:04 AM
  4. Air Conditioning
    By 10spokess in forum General Help
    Replies: 5
    Last Post: 04-12-2011, 05:44 AM
  5. suburban air conditioning
    By Wayne Selzler in forum General Help
    Replies: 0
    Last Post: 01-02-2006, 07:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •