Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Fix my WOT ping/knock!

This is a discussion on Fix my WOT ping/knock! within the General Help forums, part of the LSx Technical Help Section category; I need some suggestions on what to do. At WOT between 5k RPM-redline my 2001 WS6 M6 has a snapping/clicking ...

  1. #1
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Angry Fix my WOT ping/knock!

    I need some suggestions on what to do. At WOT between 5k RPM-redline my 2001 WS6 M6 has a snapping/clicking sounding knock coming from the driver's side engine. It does it more when temperatures are warm. I only use Shell V-Power 93 Octane fuel or Exxon Mobile 93 Octane fuel.

    In an effort to fix it I have done the following, in this order:

    -Put 1 large bottle of GM Fuel Treatment Plus through tank
    -Flushed coolant system and replaced with 50/50 dexcool (manual suggests)
    -1 bottle of seafoam through gas tank
    -Seafoam through break booster line
    -Seafoam Deep Creep into intake manifold
    -Replaced spark plugs and wires (at same time)
    -Had car dyno tuned on a mustang dyno for 93 Octane fuel

    The knocking/pinging is unchanged through all of this. It makes me wonder if it's actually ping or knock.

    Other bits of information about my car:
    Kooks LT Headers
    Kooks high-flow Cats
    Magnaflow 3.5" catback
    SLP Lid
    Bo White Ported and Polished Throttle Body
    Spohn SFCs and LCAs
    Hurst Billet Plus STS

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    is the car tuned? Have you logged it to verify it's knock and not something else like an exhaust leak?

  3. #3
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    It was tuned on a mustang dyno by a fbody shop. I've not tried to log anything yet.. I have a buddy with a laptop who may be able to assist with that next week. So I guess I haven't verified it is knock.

    I couldn't imagine where an exhaust leak would be coming from since this sound is persistent through completely upgrading the exhaust components. Anything that could be leaking has been replaced as of last week.

  4. #4
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    48
    Posts
    416

    navy blue metallic
    2001 trans am

    does it happen when you blip the throttle? Run fine cold in the morning?

  5. #5
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Does not happen when throttle is blipped or if I give it a complete rev to 6k. The knock/ping only happens under load at WOT.

    Does not happen when cold. Or at least I don't think it does - I only go WOT once the car is at operating temperature. I notice the knock/ping the most as temperatures rise outside but it could just be in my head.

    The knock/ping doesn't happen every time I drive, but if it does it once, it will keep happening the rest of the time I am driving.

  6. #6
    Junior Member
    Join Date
    Feb 2007
    Location
    Punta Gorda FL
    Posts
    15

    Black
    02 TA WS6

    My 02 WS6 A4 does the same thing-sounds like a spark knock (pre-detonation)/ping to me...and I also use Shell. Wonder if it could be the gas? Never noticed if it does it more when its hot out, but it did it the other day, and outside temp was about 90.

  7. #7
    Member
    Join Date
    Oct 2005
    Location
    Fort Rucker
    Age
    29
    Posts
    182

    Black
    2001 Trans Am WS6

    Do you have a K&N filter or some kind of oiled filter? My car did the same thing, then I yanked out the K&N because it was putting its oil through my MAF and into the combustion cycle causing knock. When I replaced it with a paper air filter and cleaned the MAF, knock went away.

  8. #8
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Paper filter. I may replace it anyway, and clean my MAF

  9. #9
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    if you can get it logged and see how much knock your getting and what kind of timing your seeing that'll help. A wideband would also be nice so you can look at your fueling and see what's going on there. Might just be a little lean or have a little to much timing. The warmer it gets outside the more apt it'll be to knock so it's not just you, it could actually be knocking more as the temps rise. What was the temps like when it was dyno tuned?

  10. #10
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Temps on the day it was dyno tuned and test driven afterwards was probably mid-60s at time of the tune.. low of the day was 45F, high was 70F, average 60F. I can't say at what temp it was tuned.. likely pushing closer to 70F.

    Yesterday it went as high at 85F.

    edit: I really appreciate you giving a sincere stab at helping me!

  11. #11
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    so you only get the taping under load? (when the entire drive line is moving)

  12. #12
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Only under load.

  13. #13
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by RandomOmen View Post
    Only under load.
    i don't think it is with your engine then... sounds drive line related...

  14. #14
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    If that's the case I wonder what it could be.

    I have plans to datalog the car on Sunday. In preparation I replaced the air and fuel filters today; I believe the original fuel filter was still in there. It was an AC Delco. No change to the "ping" though the car feels a tad smoother, likely attributable to the fresh air filter. I will be cleaning the MAF and resetting the PCM at some point before the data log.

  15. #15
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I wouldn't reset it. You're not wanting perfect trims and all that. You're wanting to see what the cars doing right now. I'd leave it alone, it'll keep the log realistic.

  16. #16
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Okay. I will hold off.

  17. #17
    Member 99WS6MAN's Avatar
    Join Date
    Dec 2005
    Location
    TX
    Posts
    309

    Red
    99 Pontiac WS.6 Trans Am

    I had the same problem and it turned out the be the knock sensor believe or not. I thinkg gtotabob is on to something. Took a Saturday afternoon and replaced both of them sinceI had everything opened. I'll admit that I ran 89 Octane only a handful of times but believe this was the culprit, I definatly learned my lesson and wont EVER put 89 again!

  18. #18
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Hopefully that's not the issue - then again I guess taking off the intake manifold isn't very tough. It'd give me an excuse to do the LS6 PCV valve upgrade.

  19. #19
    Junior Member
    Join Date
    Mar 2006
    Location
    CHESTER, VA
    Age
    49
    Posts
    11

    BLACK
    2001 WS6

    Same deal here. Knocking/pinging only at WOT, btwn 4500 and redline. worse when outside temp is warmer (horrible if >85deg F). New plugs,wires,fuel filter,air filterSeafoam through fuel and brake booster line. Only run Amoco 93oct. Cats replaced by dealer after Pontiac's pseudo-recall. Replaced SLP MAF with stock MAF. Cant figure this damn thing out, but cant race any ricers cuz I sound like crap! WTF? I don't have autotap or anything to tell me whats happening while driving. Where do I go next?

  20. #20
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    48
    Posts
    416

    navy blue metallic
    2001 trans am

    Try deleting the !Air system if it isnt. Mine was doing that until I got a header job and Air delete

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. knock knock...who's there? wait...engine knock...
    By jiveass in forum Internal Engine
    Replies: 60
    Last Post: 04-26-2011, 08:04 AM
  2. knock sensor code with new knock sensors?
    By zaaronz in forum General Help
    Replies: 13
    Last Post: 02-27-2011, 07:26 AM
  3. Ping maybe knock?
    By jetaws6 in forum Internal Engine
    Replies: 12
    Last Post: 09-27-2010, 05:39 AM
  4. Engine Ping
    By Retired Cop in forum Internal Engine
    Replies: 60
    Last Post: 01-29-2010, 05:47 PM
  5. Engine Knock Ping Might be trouble
    By dr_ws6_00 in forum Internal Engine
    Replies: 5
    Last Post: 09-15-2007, 05:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •