Results 1 to 11 of 11

Fill-up problem

This is a discussion on Fill-up problem within the General Help forums, part of the LSx Technical Help Section category; I hope you guys can help me. I'm having a problem filling up with gas. the car can be bone ...

  1. #1
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Fill-up problem

    I hope you guys can help me. I'm having a problem filling up with gas. the car can be bone dry and when i go to put gas in, it stops after about 3 gals every time, then for the rest of the tank i have to sit there and hold it. i only go to Chevron stations, but i have tried a couple of them and its all the same thing. Thanks in advance for the help.

  2. #2
    Awaiting Activation
    Join Date
    Jun 2008
    Location
    Decatur Al
    Age
    36
    Posts
    135

    NBM
    99 Z28

    I read somthing on here before about the same problem. I can't remember what the fix was but it didn't sound too hard.

  3. #3
    Awaiting Activation
    Join Date
    Jun 2008
    Location
    Decatur Al
    Age
    36
    Posts
    135

    NBM
    99 Z28

    Cant fill car up This might be it.

  4. #4
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    hey thanks alot! hope this does it

  5. #5
    I flame retards CamaroFan71's Avatar
    Join Date
    Aug 2006
    Location
    Baton Rouge, La.
    Posts
    1,068

    QuickSilverMetallic
    2005 GTO M6

    Quote Originally Posted by CamaroFan71 View Post
    Car did the same shit today after sitting since friday night. Unplugged that plug but it didnt help. Opened the green cap on the evap line and unscrewed that schrader valve, I went back to the gas tank and watched the gas go down into the tank finally. Is there anyway to remove all this evap shit without messing my car up??
    I had to do this again tonight, for the first time in a long time. Opened the green cap under the hood on the fuel line, unscrewed the schrader valve and it started taking gas right away. Does the trick every time.

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    Quote Originally Posted by CamaroFan71 View Post
    I had to do this again tonight, for the first time in a long time. Opened the green cap under the hood on the fuel line, unscrewed the schrader valve and it started taking gas right away. Does the trick every time.
    wonder if your solenoid is sticking, might want to try changing that.

  7. #7
    I flame retards CamaroFan71's Avatar
    Join Date
    Aug 2006
    Location
    Baton Rouge, La.
    Posts
    1,068

    QuickSilverMetallic
    2005 GTO M6

    Quote Originally Posted by 0rion View Post
    wonder if your solenoid is sticking, might want to try changing that.
    Yeah I went to autozone to get one but they couldnt find it in their system. When it quit doing it I just let it go. Might try to get one this weekend and just go ahead and change it out.

  8. #8
    Junior Member ricefordiner's Avatar
    Join Date
    Jan 2008
    Location
    galt ca
    Posts
    72

    black
    00 camaro Z28

    hey im from around sac too i know it has nothing to do with the thread but i have to say wazzup. i havent seen many very people from around sac on this site so yea.

  9. #9
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    ya i live in south sac right off of HYW99 not to far from Galt. its good to see someone else on here from this area.

  10. #10
    Senior Member ss~zoso~ss's Avatar
    Join Date
    Dec 2004
    Location
    )
    Posts
    9,128

    SS: NBM, tan top
    1998-SS, 2010 Jetta TDI

    do you guys think this problem is a result of running the car too low on gas, ie vapor locking it?

  11. #11
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Orion is right, probably your solenoid sticking and tank is not venting.

    To answer Camaro fans question from the previous thread,,,,yes you can remove the evap system but you will need a vented gas cap for the tank.
    Thats something the EPA doesn't like anymore, and if you have to go through an e-check it will not pass. New cars do not allow vented gas into the atmosphere anymore and I'm not even sure you could find a vented cap for the newer cars,,,never tried. They started putting the evap stuff on cars as early as 1970 if california built (my 70 formula has it) and became standard stuff in all states by 1971. Back then the evap switches were vacuum controlled and very simple,,,now that stuff is all electronic and prone to fail.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: oil fill cap
    By jodmari in forum Firebird / WS6
    Replies: 10
    Last Post: 06-11-2015, 04:44 PM
  2. Fill me in about Sea Doo's
    By adam3566 in forum Almost Anything Goes
    Replies: 16
    Last Post: 04-18-2010, 12:00 PM
  3. Fill Ins
    By kf4knf in forum Camaro / SS
    Replies: 21
    Last Post: 05-01-2008, 09:54 AM
  4. Vinyl Fill or Stainless fill?
    By sgt0704 in forum Appearance Section
    Replies: 21
    Last Post: 07-13-2007, 11:46 AM
  5. New to n2o, where to fill (HSW kit?)
    By stevegrizzle in forum Nitrous
    Replies: 8
    Last Post: 03-04-2007, 03:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •