Results 1 to 7 of 7

few questions.

This is a discussion on few questions. within the General Help forums, part of the LSx Technical Help Section category; so, i have a few questions. 1st. does anyone else have a problem w/their bright light "switch" sticking when they ...

  1. #1
    Impounded
    Join Date
    May 2008
    Location
    Verdigris, OK
    Posts
    2,165

    NBM
    99 z28

    Question few questions.

    so, i have a few questions.


    1st. does anyone else have a problem w/their bright light "switch" sticking when they turn them on? my car is doing the same thing as my other '99 camaro.
    after i turn my brights on, it takes atleast 5- 10 times of me flippin the "switch" before it goes back to just my dims. any ideas/suggestions?

    2nd. is anybody else running Firestone Firehawk tires? if so, how are they in the rain? mine are horrible. i just got back home, its pouring outside, and when i driving sometimes my car will start hydroplaning. scares the hell outta me. my back end gets sideways and i start fishtailing. of course i let off gas and correct the steering and them im back to normal. and its not like im hauling ass. majority of time its when im on the highway, going between 45mpg to 55mp.

    3rd, and final one lol. my tach just suddenly stopped working. also, while on my way home, i stopped and ran into a gas station(left my car running). when i came back out and pulled out of the gas station, i noticed my tach stopped working. the gas station is literally right up the rode from my neighborhood. so when i got home, i shut off and restart my car to see if it would work then, but nothing. stays below "0". any thoughs/suggestions/ideas?

    thanks

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Possible answers

    1) most likely the switch inside the colum is toast.
    2) Welcome to world of high performance tires and wide tread area. You will get that with most performance oriented tire.
    3) most likely a fuse or broken wire

  3. #3
    Impounded
    Join Date
    May 2008
    Location
    Verdigris, OK
    Posts
    2,165

    NBM
    99 z28

    Quote Originally Posted by Orcus79 View Post
    Possible answers

    1) most likely the switch inside the colum is toast.
    2) Welcome to world of high performance tires and wide tread area. You will get that with most performance oriented tire.3) most likely a fuse or broken wire
    it hasnt always done it. i noticed it about 2-3 months ago. ive had these tires for almost 2 years. their is still plenty of tread left on them.

    thanks for replies

  4. #4
    Member totalkos's Avatar
    Join Date
    Oct 2007
    Location
    New Orleans
    Age
    30
    Posts
    389

    Nbm
    2000 Camaro SS

    i had those tires on my 92 camaro z28 they were really bad about hydroplaining, more than normal anyways.

    My current tires on my 2000 ss arent near as bad about it. still do it occasionally

  5. #5
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    My friends dad has those on his c4 and in rain he can just about spin at idle. They are horrible.

  6. #6
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    the cooper tires I had drove like crap in the rain...........bought some cheaper Riken Raptors and they do great in the rain

  7. #7
    Impounded
    Join Date
    May 2008
    Location
    Verdigris, OK
    Posts
    2,165

    NBM
    99 z28

    well, jus got back from getting my lil girl donuts and my tach is working now. so thats good. as far as the "bright" switch, im not too worried about it( i never use them). i was just curious to see if anyone else encounters this problem on their f-body. kinda glad to hear about the tires, that its not just my set.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A few questions
    By blackcar in forum External Engine
    Replies: 5
    Last Post: 01-30-2012, 12:35 PM
  2. Replies: 6
    Last Post: 12-30-2011, 12:40 PM
  3. z28 questions
    By stickinpcb in forum Internal Engine
    Replies: 2
    Last Post: 04-25-2007, 02:37 PM
  4. Questions
    By The Silver Goat in forum GTO
    Replies: 2
    Last Post: 04-22-2007, 08:26 PM
  5. Questions
    By Airguy in forum Firebird / WS6
    Replies: 3
    Last Post: 04-21-2007, 01:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •