Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Exhaust backfiring

This is a discussion on Exhaust backfiring within the General Help forums, part of the LSx Technical Help Section category; I have the SLP Loudmouth exhaust like the title implies it is backfiring lately. I get it sometimes right when ...

  1. #1
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    33
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Exhaust backfiring

    I have the SLP Loudmouth exhaust like the title implies it is backfiring lately. I get it sometimes right when i start the car but it is inconsistent. I get it rarely when I let off the gas, but I read some forums that said it's normal? All I know is that it didn't used to backfire at all and it is slowly doing it more and more. It's pretty embarrassing though to be honest. Can anyone help?

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    there's a difference between the exhaust popping and a backfire. If it's exhaust popping then that is normal with a free flowing exhaust like a loudmouth. I would bet that's what your hearing. A backfire is more of just one loud pop and the car will stumble usually.

  3. #3
    Member 89LX's Avatar
    Join Date
    May 2006
    Location
    East Coast North Carolina
    Posts
    429

    Navy
    2000 Z28 M6

    Popping

    I would guess it is normal popping. A backfire will scare the crap out of the general population and send mothers with children into WOT.
    2000 Z28 M6, SLP Lid, SLP Bellows, SLP UD,
    P&P Maf, TB By-Pass, PS Shorties, LS6 Intake, FAST 78mm TB, Hooker CB, Hurst Billet, Front Tower Brace, small 218/218....527/527....114 cam.
    337rwhp/348rwtq

  4. #4
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    LMAO @ mothers w/children into WOT...

    Anyways, if you haven't tuned the car since opening up the catback, its probably just popping @ startup due to the idle speed the car is calling for when cold.

    Shouldn't be a problem.

    -Eagle
    Last edited by Eagle; 04-30-2008 at 08:59 AM.

  5. #5
    Senior Member 00LS12LS6Z28's Avatar
    Join Date
    Jul 2007
    Location
    Bristow, VA
    Posts
    663

    Black
    2000 Camaro Z28 (sold)

    I have the SLP Loudmouth as well but with stock cats and have the same issue (I get some popping when I shift too) I have edelbrock headers as well. I thought it was because I have stock cats and they were holding back. But I think it is because we have a resonator instead of a muffler. Do you have stock cats and or headers?

  6. #6
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by 89LX View Post
    I would guess it is normal popping. A backfire will scare the crap out of the general population and send mothers with children into WOT.
    uncle buck is a back fire.

    watch that movie if your car does that you do have a problem.


  7. #7
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by 00LS12LS6Z28 View Post
    I have the SLP Loudmouth as well but with stock cats and have the same issue (I get some popping when I shift too) I have edelbrock headers as well. I thought it was because I have stock cats and they were holding back. But I think it is because we have a resonator instead of a muffler. Do you have stock cats and or headers?
    mostly when it is cold?

  8. #8
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    33
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Quote Originally Posted by 00LS12LS6Z28 View Post
    I have the SLP Loudmouth as well but with stock cats and have the same issue (I get some popping when I shift too) I have edelbrock headers as well. I thought it was because I have stock cats and they were holding back. But I think it is because we have a resonator instead of a muffler. Do you have stock cats and or headers?
    I do have headers. I think the cats are gone (not sure though)

  9. #9
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    33
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Quote Originally Posted by 1fastcamarosss11 View Post
    mostly when it is cold?
    It does seem mostly when it's cold. But still inconsistent, like today colder than yesterday and no popping. Yesterday it did however. From the sounds of it, it is only popping and not backfiring.

  10. #10
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert



    about 1 min 15 seconds in lol.

  11. #11
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    33
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Quote Originally Posted by 1fastcamarosss11 View Post


    about 1 min 15 seconds in lol.
    I'll have to watch when I get home... damn work filters...

  12. #12
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by LOCKDOWN View Post
    I'll have to watch when I get home... damn work filters...
    i just saw your west of cleveland where abouts? lakewood here.

  13. #13
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by LOCKDOWN View Post
    I have the SLP Loudmouth exhaust like the title implies it is backfiring lately. I get it sometimes right when i start the car but it is inconsistent. I get it rarely when I let off the gas, but I read some forums that said it's normal? All I know is that it didn't used to backfire at all and it is slowly doing it more and more. It's pretty embarrassing though to be honest. Can anyone help?

    emarassing?!? that is manly... not embarassing...

  14. #14
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    33
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Quote Originally Posted by 1fastcamarosss11 View Post
    i just saw your west of cleveland where abouts? lakewood here.
    Haha! I go right through lakewood to work. I have actually partied in lakewood a few times. I live in avon lake. Ever go to Johnny Malloys?

  15. #15
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by LOCKDOWN View Post
    Haha! I go right through lakewood to work. I have actually partied in lakewood a few times. I live in avon lake. Ever go to Johnny Malloys?
    used to not much anymore, that place is way to crowded, and after 11:30 pm or so everyone seem like they want to fight. lol.

  16. #16
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by 1fastcamarosss11 View Post
    used to not much anymore, that place is way to crowded, and after 11:30 pm or so everyone seem like they want to fight. lol.
    sounds like fun...

  17. #17
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by Spaz View Post
    sounds like fun...
    i'm getting older an not single.
    back in the day is was a meat market lol.

  18. #18
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    46,150 posts... clearly that stat is padded. :P

  19. #19
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by Eagle View Post
    46,150 posts... clearly that stat is padded. :P
    no sadly it is not.

  20. #20
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by 1fastcamarosss11 View Post
    i'm getting older an not single.
    back in the day is was a meat market lol.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. backfiring at low rpm
    By V8MUSCLE in forum General Help
    Replies: 28
    Last Post: 12-21-2010, 05:58 PM
  2. backfiring(please help)
    By Boomer Sooner in forum General Help
    Replies: 6
    Last Post: 08-16-2008, 09:12 PM
  3. should it be backfiring?
    By bgable in forum External Engine
    Replies: 15
    Last Post: 06-18-2008, 08:54 PM
  4. Backfiring!
    By Pappa Doo in forum Internal Engine
    Replies: 10
    Last Post: 09-06-2007, 08:50 PM
  5. backfiring
    By 94formulaLT1 in forum LT1
    Replies: 4
    Last Post: 03-15-2006, 08:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •