Results 1 to 8 of 8

Engine Stutter at 2600 RPM!

This is a discussion on Engine Stutter at 2600 RPM! within the General Help forums, part of the LSx Technical Help Section category; When in any gear (M6) as soon as my rpm reaches 2600 the engine stutters as if i let off ...

  1. #1
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    Engine Stutter at 2600 RPM!

    When in any gear (M6) as soon as my rpm reaches 2600 the engine stutters as if i let off the throttle a little bit. It runs excellent otherwise and it only does it at exactly 2600 rpm. The funny thing is it wont do it in neutral. Any Ideas? My mods are K&N inatke, ls6 manifold, msd ignition, magnaflow catback, some more but not perfomance related. I really cant think of what could cause that, it runs fine, have the valve covers off to replace a pushrod and everything was very clean.Thanks!

  2. #2
    Member dav-02ws6-m6's Avatar
    Join Date
    Mar 2010
    Location
    VA
    Posts
    294
    2002 trans am ws6

    i might have the same problem as you. in my car it feels like a missfire but no codes..

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Why did you replace a pushrod? Did it stutter befor you replaced the rod?
    Just my opinion but i would ditch the K&N filter and clean the maf to ensure there isnt any oil on the Maf.
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Our car came with a hacked up MAF and a stutter right around 1,500 r.p.m. Replaced the MAF and the stutter went away. Have you cleaned your MAF lately, or has it been modified in any way?

  5. #5
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    i do not beleive the MAF has been modified, but I havnt checked. I do plan on doing the port and polish and bump stop mod though. I did seafoam it just last week but that didnt change anything, I seafomed it thruought the brake booster, I dont know if that would have cleaned the MAF.

  6. #6
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    Quote Originally Posted by sunsetorangess View Post
    Why did you replace a pushrod? Did it stutter befor you replaced the rod?
    Just my opinion but i would ditch the K&N filter and clean the maf to ensure there isnt any oil on the Maf.
    J
    bent the pushrod by misshifting, what do u mean by ditch the k&n? what would I replace it with? arnt those some of the best?

  7. #7
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Some will say go back to the stock paper filter, or AMSOil. My car came with a K&N but when I clean/re-oil, I make sure I don't over-oil the filter. If I do, I make sure I have newspaper/paper bag handy to soak up the oil.

  8. #8
    Member camaroluvr447's Avatar
    Join Date
    Sep 2009
    Location
    Steubenville, Ohio
    Age
    27
    Posts
    234

    Pewter
    2000 Pewter Z28 M6

    i will do some research on the k&n, but i dont think a air filter could cause something so exact and noticeable. If I put it in gear and just keep the rpm bouncing between 2400 and 2600 it will do it over and over and it is really noticeable then. Im mainly worried that it could mean bad things for my engine!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 99 z28 lag/stutter please help!!
    By clewis05 in forum General Help
    Replies: 85
    Last Post: 03-29-2015, 10:52 AM
  2. engine stutter issue
    By iamsam38 in forum Member's Rides
    Replies: 0
    Last Post: 06-04-2010, 12:09 AM
  3. 2006 Hayabusa 2600 miles sale or TRADE
    By nitrobusa in forum Vehicles For Sale / Trade
    Replies: 0
    Last Post: 03-30-2008, 08:46 PM
  4. 2600 stall converter... is it worth it?
    By z28punk in forum Automatic Transmission
    Replies: 9
    Last Post: 03-30-2008, 08:45 PM
  5. car stutter?
    By Justin23454 in forum General Help
    Replies: 4
    Last Post: 01-20-2008, 08:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •