Results 1 to 18 of 18

Engine squeal

This is a discussion on Engine squeal within the General Help forums, part of the LSx Technical Help Section category; Has anybody had a high-pitched squeal coming from their engine? It sounds like a brake squeal when the pads need ...

  1. #1
    y2kz28
    Guest

    Engine squeal

    Has anybody had a high-pitched squeal coming from their engine? It sounds like a brake squeal when the pads need to be changed. The noise goes away as soon as any load is put on the engine. If it's doing it at idle, if I increase the rpms, it goes away. Sometimes it'll do it when I'm driving down the road and have let off the throttle. But again as soon as I press on the gas, it goes away. I've heard it could possibly be a serpentine belt. When I had the oil changed last time, I was told the belt looked fine. How about an idler pulley? Any input would be greatly appreciated.

  2. #2
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,526

    Black
    383 Procharged & N20 Vert

    Most likely its the belt.

  3. #3
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    Sounds like the belt

  4. #4
    y2kz28
    Guest
    Thanks for getting back to me. I appreciate it.

  5. #5
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    97 lt1

    i had an lt1 that did the same thing and it was the belt, to test u can try and buy some of that cheap belt spray that "fixes" the problem for about two minutes and spray it on there, if it works then just replace the belt.

  6. #6
    y2kz28
    Guest
    Okay, thanks for the tip. It's frustrating because it doesn't do it all of the time.

  7. #7
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    my belt tensioner made a hell of a racket when it started going bad? but I dont know jack?

  8. #8
    y2kz28
    Guest
    Okay, thanks. I'll have to look into it further. I appreciate all of the input. 1SSWFO, what type of noise was it making?

  9. #9
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    I thought it was the belt too and sprayed the belt dressing on it and it did stop for about 2 seconds, but then back to a loud squeel kinda and the belt dressing made one hell of a mess.

  10. #10
    y2kz28
    Guest
    Okay, thanks. Was the tensioner expensive? The last time I heard the noise, I crawled under the car, and it sounded like it was coming from the passenger side near the bottom. It looks like there's another tensioner just above and towards the driver's side of the AC compressor. I sprayed it down w/lube and it went away. But along with the squeal, it almost has kind of a metal on metal sound. Is that about what you had too?
    Last edited by y2kz28; 09-16-2005 at 09:12 PM.

  11. #11
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    ? I cant remember I think I paid about $100 for it but I cant remember. I replaced the Idler pulley too it also made noise similar I think? I must be getting old or oldtimers I cant remember alot after yesterday but good luck.

  12. #12
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    these guys give better info than I do

  13. #13
    y2kz28
    Guest
    Thanks again.

  14. #14
    ls1freak
    Guest
    it's most likely your belt i have had to replace mine two times because it sounded horrible when i rode around. I also replaced the ac belt while i had the serpentine off just to be safe

  15. #15
    down in it 310stanger's Avatar
    Join Date
    Aug 2005
    Location
    nj
    Age
    34
    Posts
    10,976

    white
    90 Mustang 5.0

    like stated before, i would always start with the $20 or so belt. easy enough to change and a cheap fix if that is the problem.

  16. #16
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    true the belt is cheaper.

  17. #17
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    alot.

  18. #18
    y2kz28
    Guest
    thanks for the input.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •