Results 1 to 3 of 3

Engine runs rough, idles rough, runs rich

This is a discussion on Engine runs rough, idles rough, runs rich within the General Help forums, part of the LSx Technical Help Section category; I was looking at replacing my fuel pressure regulator to remedy issues that stump every mechanic to date. No codes ...

  1. #1
    Junior Member
    Join Date
    Aug 2006
    Location
    michigan
    Posts
    4

    Cozumel Blue
    99 Firebird

    Engine runs rough, idles rough, runs rich

    I was looking at replacing my fuel pressure regulator to remedy issues that stump every mechanic to date. No codes thrown. Plugs and wires changed. Rough starts, rough idles, black smoke, minor hesitation / misfires during acceleration....just had $100 enema to cleanse the engine...didn't help.
    3.8L V6 99 Firebird (wants to be an LS1 someday).
    Injectors are cleaned. Can this be affiliated with a short to the multi function steering stalk switch that occassionally decides to billow white electrical smoke up the Steering column?
    Vehicle used to run excellent, then threw code P1441 emmissions which went away with replacing gas cap. Dealerships and private mechanics all stumped, and my wallet is getting thinner by the day seeking a remedy.
    Someone said check vacuum line from intake to fuel regulator?
    Another person asked if PCM reflashed after cat replacement...YES!
    Who likes challenges out there?
    Last edited by skintox; 08-22-2006 at 11:28 AM.

  2. #2
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,123
    Retired Outlaw Sum Bitch

    This is posted in the wrong section and I'm sure a mod will move it for you....then you'll get some replies....turn your internet filters on high as you solicited a crap shoot....let me take a swipe at it though while I'm on here....
    You have probably mutiple problems....If I understand your post ....dealerships/mechanics have all diagnosed/troubleshot this thing....the normal approach was to eliminate fuel pressure/air fuel/ignition/etc and all of these system report normal ops ( I assume)....
    From what you described and with the assumption all the above mentioned obvious systems have been checked and cleared...I would suspect valves...sounds like you have a compression/valve issue. Have "them" check your compression...valves.....
    As for the smoke coming out of your steering column...I would "guess' that is a dead ass short and it burns the insulation of the shorted wire thus the smoke....easy to find and fix...

  3. #3
    Senior Member MadSeason's Avatar
    Join Date
    Aug 2005
    Location
    Indiana
    Age
    34
    Posts
    2,000
    1994 POS

    moved this to general help... i can't think of anything sarge hasn't said already

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •