Results 1 to 7 of 7

Engine idling fast

This is a discussion on Engine idling fast within the General Help forums, part of the LSx Technical Help Section category; This weekend the engine in my TA started idiling faster than usual once it got good and warm. It wants ...

  1. #1
    Member ronnie tadlock's Avatar
    Join Date
    Oct 2008
    Location
    Hickory, NC
    Posts
    158

    Pewter
    2001 Trans Am WS-6

    Engine idling fast

    This weekend the engine in my TA started idiling faster than usual once it got good and warm. It wants to idle around 1200 rpm and the rpms want to stay high between gear changes (6-speed). If I'm driving in town, I can let off the gas and the car almost feels like the cruise control is on, but it's not. Any idea what is causing this?

  2. #2
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    any recent mods? You IAC might be dropping, try adjusting the TB Blade and reseting it.

  3. #3
    Member ronnie tadlock's Avatar
    Join Date
    Oct 2008
    Location
    Hickory, NC
    Posts
    158

    Pewter
    2001 Trans Am WS-6

    The motor is bone stock. It just started this past Saturday. I removed the airbox and cleaned the TB blade on Sunday. I thought it may be stuck and not closing all the way. Could bad gas maybe cause it? I filled up Saturday afternoonand always run 93 octane. It idles fine until iI drive it a while and it gets really warmed up.

  4. #4
    Junior Member
    Join Date
    Jul 2006
    Location
    tx
    Posts
    24

    white/black
    2002 Camaro Z28

    clean your maf and iac... remove both from car and clean well with crc? maf cleaner.. check other posts on here regarding cleaning your iac.. mine was really bad.. made a huge difference after i cleaned it. I had the same exact problem you are having. i also cleaned the throttle body when i removed the iac.. lots of carbon and gunk in there.. don't replace anything til you try cleaning those sensors first!

  5. #5
    Junior Member
    Join Date
    Jul 2006
    Location
    tx
    Posts
    24

    white/black
    2002 Camaro Z28

    also.. make sure you have no vacuum leaks.. that will also do it..

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    check the back of your pcv hose where it turns to go into the inake on the passenger side. Those are known to develope a crack back there and that'll cause what you're describing. Either way I'd say you're getting some unmetered air in there somewhere.

  7. #7
    Member ronnie tadlock's Avatar
    Join Date
    Oct 2008
    Location
    Hickory, NC
    Posts
    158

    Pewter
    2001 Trans Am WS-6

    I can't find a leak anywhere, but get this. I stopped to get gas and it was idiling high again. After I got my gas and restarted it, it idled fine. Then it started idiling crazy again before I got home. Turned it off for about 30 seconds, restarted it and it idled fine again. Could it be the TPS?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Need engine fast!
    By BashamWS6 in forum General Help
    Replies: 62
    Last Post: 04-21-2011, 07:08 AM
  2. Idling
    By edrvsqz1980 in forum Firebird / WS6
    Replies: 27
    Last Post: 07-22-2010, 03:15 AM
  3. Idling RPM's?
    By qwk01ta in forum General Help
    Replies: 3
    Last Post: 04-27-2010, 11:09 PM
  4. My Camaro idling
    By Kamauxx in forum Camaro / SS
    Replies: 4
    Last Post: 10-05-2007, 06:46 PM
  5. Idling at 650 to 750 RPM's
    By 9t8z28 in forum External Engine
    Replies: 4
    Last Post: 10-31-2006, 07:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •