Results 1 to 2 of 2

electrical problem

This is a discussion on electrical problem within the General Help forums, part of the LSx Technical Help Section category; So last night while i was out cruising, my volt guage starts jumping around going crazy. While its doing that, ...

  1. #1
    Junior Member
    Join Date
    Sep 2005
    Location
    Lancaster, PA
    Age
    35
    Posts
    98

    black
    2000 Z28 (sold)

    electrical problem

    So last night while i was out cruising, my volt guage starts jumping around going crazy. While its doing that, my lights get dim. As I am driving it home the guage goes down into the red and stays there. Now i just had a new battery installed the other week. So, i replace the alternator. That doesnt fix the problem. I am not too familiar with the electronics, so i dont know what to do next. Anyone have any ideas? Thanx.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    check your battery terminals and make sure there tight and clean then recheck your connections on ur alt.
    hook up a multimeter to your batter or alt and see what the voltage is
    J

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •