Results 1 to 5 of 5

electrical problem...

This is a discussion on electrical problem... within the General Help forums, part of the LSx Technical Help Section category; ok after I am driving for a while with the air on and I come to a stop light my ...

  1. #1
    phoenix99ta
    Guest

    Question electrical problem...

    ok after I am driving for a while with the air on and I come to a stop light my alt guage goes way down to the red to like 7 volts... oil guage goes low as well... as I start to move everything is fine... I replaced alt still the same...another thing is the dash lights dim or blink when I step on the brake ... any ideas???

  2. #2
    Ahh crap... needmorepwr's Avatar
    Join Date
    Aug 2005
    Location
    SoCal
    Posts
    1,761
    '57,'63,'70,'91,'01

    It sounds like the gauges have a bad ground. check to see if the connections are all tight. On some cars the bolts that hold in the gauges are the ground.

  3. #3
    phoenix99ta
    Guest
    do I have to take the dash apart? could it be in the hvac controls???

  4. #4
    phoenix99ta
    Guest

    Cool

    also it only happens when the car is runnung a while and at a stop with the car in drive... I have had an aftermarket stereo installed for years never any problems... the voltage is actually dropping because the amp shuts down ... I did disconnect the amp and no change .. I shut the a/c when the volts drop and no change ... it is baffling I hope it is the ground as you think...

  5. #5
    phoenix99ta
    Guest

    Exclamation

    I think it has to do with te cooling fans when they click on the voltage drops... are they expensive to replace???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •