Results 1 to 5 of 5

Electrical Issues

This is a discussion on Electrical Issues within the General Help forums, part of the LSx Technical Help Section category; When my car is running the amp meter was always in the red, sometimes pretty low. After a few weeks ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    FORT LAUDERDALE
    Age
    31
    Posts
    36

    WHITE
    1998 CAMARO

    Electrical Issues

    When my car is running the amp meter was always in the red, sometimes pretty low. After a few weeks of driving like this the batter pooped out. My first impulse was the alternator wasnt putting out enough volts. I had it checked and they said it was fine. What else could be wrong?

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    The battery, the cables between the alternator and the battery. NEVER drive with a gauge in the red for an extended period, you will only damage more stuff. Hope fully all you fried was the battery, very possibly you could have cooked your AC compressor clutch too from it not getting enough voltage allowing it to slip.

  3. #3
    Junior Member
    Join Date
    Aug 2005
    Location
    FORT LAUDERDALE
    Age
    31
    Posts
    36

    WHITE
    1998 CAMARO

    how would i know if the AC clutch was going because of this...

    i brought it to auto zone and the guy heard the bearings squeeking. he said the bearings are loose and this does not allow a good connection. although the alternator tested fine, he said, once its on the car and it has the AC, lights, etc running is when it wont put out enough volts. does this sound reasonable?
    Last edited by drock608; 07-29-2008 at 03:26 PM.

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    you won't really till it fails or starts making noise. The only way to tell for sure is to tare it down. but if you have noticed a decrease in ac performance an all the pressures check out, that may be the cause.

  5. #5
    Junior Member
    Join Date
    Aug 2005
    Location
    FORT LAUDERDALE
    Age
    31
    Posts
    36

    WHITE
    1998 CAMARO

    thanks for the help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Electrical issues
    By jcddllc in forum General Help
    Replies: 2
    Last Post: 01-31-2015, 06:07 AM
  2. Not Sure if im having electrical issues
    By my1stss in forum Camaro / SS
    Replies: 6
    Last Post: 05-30-2011, 12:49 PM
  3. Help: Electrical issues
    By SuperStock in forum General Help
    Replies: 8
    Last Post: 07-10-2008, 11:29 AM
  4. electrical issues
    By QWKRDSS in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 05:02 PM
  5. Electrical stupidy issues
    By MaxPlusTen in forum General Help
    Replies: 2
    Last Post: 05-15-2007, 05:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •