Results 1 to 2 of 2

Electrical issue please help!

This is a discussion on Electrical issue please help! within the General Help forums, part of the LSx Technical Help Section category; After I got back from the track I noticed that my turn signals dont work..nothing no power at all...its not ...

  1. #1
    Member Stricken1's Avatar
    Join Date
    Sep 2006
    Location
    Florida
    Posts
    248

    Black
    2001 Trans Am WS6

    Electrical issue please help!

    After I got back from the track I noticed that my turn signals dont work..nothing no power at all...its not like they freeze like when you have a bad bulb. So I pull the fuse and the 20 amp fuse is blown. I replace it and they are fine...now the problem, when I put the car into reverse the fuse blows again. I pulled the taillights and the bulbs are fine. Does anyone have any idea where to check for the problem? Also whe the turn signal B/U light fuse blows I have no driverside brake light either which is strange cause the brake lights are on a different fuse. PLEASE HELP! TX.

  2. #2
    Member
    Join Date
    Oct 2006
    Location
    Oklahoma City
    Posts
    282

    00 LS1, WS6, V8 Gremlin
    96 & 98 GTPs, 64 'Cuda

    If it isn't one of the bulb sockets chances are the wiring harness has a bare place in it and is touching the frame somewhere between the fuse and the light sockets. Could be an easy one to find, could be real trouble.

    Best thing to do is replace the fuse with one of those 12V test lights and pull both reverse light bulbs. Now turn the key on (but don't start the engine) and observe the test light - it should be off. Put the car in reverse and the light will probably come on full.

    Figure a way to watch that light (or get a helper) and start moving the wiring harnesses around as best you can, hopefully you'll find a place where when you move it the light goes back out. You'll now be very near to where the short is occuring.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Electrical Exhaust Cutout or Loudmouth???
    By showtimesteele99SS in forum External Engine
    Replies: 6
    Last Post: 04-15-2007, 10:02 PM
  2. Three transmissions later = electrical problems ???
    By t-topsonline in forum Automatic Transmission
    Replies: 7
    Last Post: 02-21-2007, 11:13 PM
  3. Electrical Help
    By dlcully in forum General Help
    Replies: 4
    Last Post: 05-02-2006, 11:20 AM
  4. Water in front electrical connectors.
    By Racefan in forum General Help
    Replies: 3
    Last Post: 01-23-2006, 04:34 AM
  5. electrical cut out with LT headers
    By TransAmBeast08 in forum External Engine
    Replies: 4
    Last Post: 01-04-2006, 02:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •