Results 1 to 8 of 8

electrical?

This is a discussion on electrical? within the General Help forums, part of the LSx Technical Help Section category; so after 3 days of trouble shooting my car after my h/c install my car still will not start. problems ...

  1. #1
    Junior Member
    Join Date
    Feb 2007
    Location
    ft.hood, tx
    Posts
    1

    pewter
    2000 Z28

    Exclamation electrical?

    so after 3 days of trouble shooting my car after my h/c install my car still will not start. problems that i have; no spark and no fuel past the injectors. the fuel is getting to the fuel rail, but not getting past the injectors so the pump is running. i have continuity at every ground i can find(including the 3 on the back of the d/s head.) every plug i can see is plugged in. i am almost to the point of taking it in to the chevy dealership and have them figure it out . can anyone with some pretty good electrical knowledge of our lsx beauties please, please, please help me out. i really want to get this thing running and test out the knew h/c package i just installed. thanks

  2. #2
    Member SSpdDmon's Avatar
    Join Date
    May 2006
    Location
    Farmington, MI
    Age
    36
    Posts
    332

    SOM
    '01 Camaro SS

    Does it crank?

  3. #3
    Impounded
    Join Date
    Feb 2007
    Location
    Pa
    Posts
    276

    Red
    99 TA

    would be nice if you explained what you installed and what the trouble is in detail.

  4. #4
    Member
    Join Date
    Oct 2006
    Location
    Oklahoma City
    Posts
    282

    00 LS1, WS6, V8 Gremlin
    96 & 98 GTPs, 64 'Cuda

    No spark and no injector pulses - there's one common feed for that. Take your choice of tracing it out.

    Get one of those 0.99 test lights and see if you've got +12V on the injectors, or look at one of the coils and see if it's there. Back up to the source which will be in the underhood fuse box. If you've got power on the fuse in there carefully check the wiring harness.

  5. #5
    Junior Member greenvilleTA's Avatar
    Join Date
    Nov 2006
    Location
    Greenville, TX
    Age
    40
    Posts
    62

    White
    98 Trans Am

    If all worked before the head/cam install, most likely nothing just stopped working unless you didn't disconnect the battery and something grounded to power. I'd take a very good look around and make sure all wires and connectors are hooked up and that none are dangling. Just a side note, but you mentioned grounds on the DS...there is also 1 more on the PS. If all checks out, I agree...get an voltmeter and unplug an injector plug, then see if you get 12V while trying to crank...you might try pumping the pedal while trying.

  6. #6
    Member
    Join Date
    Oct 2006
    Location
    Oklahoma City
    Posts
    282

    00 LS1, WS6, V8 Gremlin
    96 & 98 GTPs, 64 'Cuda

    These are the times I wish I could have my Helm's manuals CDs where I could post a few images, working on that.

    No, you can't get copies of my CDs due to copyright, you can however buy your own or get a set of real GM manuals in print for a specific car directly from them. The DC set is the best deal, costs a it more but you get all GM for a range of years.

    This should not be hard to figure out. Our vehicles run with +12V going to most things and being switched to ground by the PCM. In some cases it's a +5V supply coming from the PCM. Confusing perhaps, but you people can tear engines apart in your sleep, you can certainly understand the electronics with your aptitudes.

    Millions of wires, only a few to address.

  7. #7
    Slower Than a 3rd Gen juiced99ws6's Avatar
    Join Date
    Aug 2005
    Location
    Cape Coral, FL
    Age
    32
    Posts
    3,097

    Mystic Teal
    99 Trans Am & 01 CBR 929

    where can one go to buy those manuals that you speak of? I myself am much better with wires than engine (even though im learning the best I can) since thats what I do for a living and I would LOVE to have some manuals that could help with stuff like this.

  8. #8
    Member
    Join Date
    Oct 2006
    Location
    Oklahoma City
    Posts
    282

    00 LS1, WS6, V8 Gremlin
    96 & 98 GTPs, 64 'Cuda

    Why not own what the dealers own?

    http://www.helminc.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Three transmissions later = electrical problems ???
    By t-topsonline in forum Automatic Transmission
    Replies: 7
    Last Post: 02-21-2007, 11:13 PM
  2. Electrical problem??
    By z28tito in forum New Member Introductions
    Replies: 1
    Last Post: 10-25-2006, 07:23 AM
  3. Electrical wiring diagram for LS2 ignition coils?
    By TeamX in forum General Help
    Replies: 0
    Last Post: 05-04-2006, 01:02 AM
  4. Electrical Help
    By dlcully in forum General Help
    Replies: 4
    Last Post: 05-02-2006, 11:20 AM
  5. Water in front electrical connectors.
    By Racefan in forum General Help
    Replies: 3
    Last Post: 01-23-2006, 04:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •