Results 1 to 12 of 12

ECT sensor location? DTC P0128

This is a discussion on ECT sensor location? DTC P0128 within the General Help forums, part of the LSx Technical Help Section category; Hey everyone- ***UPDATE***: ECT sensor replaced and the car is still surging when cold. This past weekend my service engine ...

  1. #1
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    ECT sensor location? DTC P0128

    Hey everyone-

    ***UPDATE***: ECT sensor replaced and the car is still surging when cold.

    This past weekend my service engine light came on and I'm seeing code P0128. I'm guessing its the ECT sensor, because I can actually see the guage on the dash changing temp by 20-30* while the car is warming up.

    Also, when its cold started you can hear the engine surging and see the tach vary 200-300RPM. The exhaust also smells rich until the car reaches operating temp.

    Can someone tell me where the ETC coolant sensor is located? I see a sensor in the front of the driver's side head, but I think there are two sensors and I want to obviously replace the correct sensor.

    I would take it to the dealer to fix under warranty, but I don't think the sensor cost warrants me pulling the nitrous system out of the car...

    -Eagle
    Last edited by Eagle; 05-30-2007 at 06:06 AM.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Just the one sensor, the one on the drivers side head. Make sure you're not low on coolant and the connector is tight...GM list is around $25, cheaper at your local parts store.

  3. #3
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    Here is the gmparts direct info on the ECT sensor:

    GM PART # 12551708
    CATEGORY: Computer Control Sensors
    PACK QTY: 1
    CORE CHARGE: $0.00
    GM LIST: $21.49
    OUR PRICE: $12.74


  4. #4
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Did you get that number from my post in the other thread? That's for the '98 sensor (3 wire) - '99 and up are different (2 wire). Believe the PN you want is 15326388?

  5. #5
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    Yep, mine is a 2 wire sensor... hrmm...

    GM PART # 15326388
    CATEGORY: Computer Control Sensors
    PACK QTY: 1
    CORE CHARGE: $0.00
    GM LIST: $31.88
    OUR PRICE: $16.58

    Crud. How do you find these PNs? I would love to know if there is a place online that can convert PNs or even do lookups for GM PNs.

    -Eagle

  6. #6
    Senior Member rajiv1998's Avatar
    Join Date
    Sep 2006
    Location
    New Jersey
    Age
    29
    Posts
    1,489

    Black
    1998 Pontiac Trans Am

    just broke mine a few weeks ago changing my plugs/wires. Mine did the xact same thing, the revs starting shooting up and down, and the idle was verrry choppy. Sounded like i had a cam in the car. Its locate near the #1 plug on the drivers side

  7. #7
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I have a 93-02 Camaro parts manual CD I bought off ebay a few years ago - but GM changes PN's all the time so sometimes it's useless. Just happened to see someone go through the same thing on another board and wrote them down. I'd get one from the local parts store anyway.

  8. #8
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    Yep, my local Autozone lists it at $23. Looks like I'll be going past there tonight on the way home from the office.

    Thanks for the help fellaz!

    -Eagle

  9. #9
    Junior Member
    Join Date
    Sep 2006
    Location
    s.e. ma
    Age
    63
    Posts
    22

    primer
    65 nova

    if the thermostat is stuck open or the coolant is low you will get a P0128
    also most P0128's i see at work are stuck open thermostats

  10. #10
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    ***UPDATE***

    Replaced the ECT sensor, but she's still surging when cold...

    IAC or IAT? Is there a way to test out the IAT sensor? Is there a best practice for cleaning the IAC?

    Dont think its the MAF because it seems to run perfectly once its warmed up and @ WOT even when not fully warmed up...

    Suggestions?

    -Eagle

  11. #11
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Did the SES go off/did you clear it and give it a few warm up cycles? If the code comes back very well could be a stuck open tstat. www.gearchatter.com/viewtopic9378.php

  12. #12
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    What I don't understand is how a stuck open tstat could cause the car to surge @ idle when cold.

    I'll grab my bud's scanner and clear the codes again, we'll see if that helps.

    If the tstat is stuck open, and the ECT is reading properly now, how could that cause the idle to bounce around 200-300RPM until at operating temperature?

    -Eagle

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •