Results 1 to 15 of 15

does idling have anything to do with o2 sensors?

This is a discussion on does idling have anything to do with o2 sensors? within the General Help forums, part of the LSx Technical Help Section category; i have a problem and its very annoying. my ses light is on after header install. i got 2 rear ...

  1. #1
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    does idling have anything to do with o2 sensors?

    i have a problem and its very annoying. my ses light is on after header install. i got 2 rear 02 deleted. plugged em in and the scanner is saying no reading from 02 sensors and low voltage to o2 sensors. bad o2 maybe? they worked before header install on stock exhaust. Also does 02 sensors have anythin to do with how the car idles? the car idles too high. like 1400-1500rpm. and when im driving and put in neutral coasting it will like sit at 2000rpm until im completely stopped. i dont know what to do about it. anyone have any suggestions or have this problem?

  2. #2
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    02 sensors going bad after header install is fairly common, so step number 1 replace them. Idle hanging until you stop is normal, the idle table does not come into play until below like 2mph. High idle is not normal, but replace the sensors and do the idle relearn, then see what you have.

  3. #3
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    The coating on new headers has been known to fowl out O2 sensors. Is the problem the same whether the engine is warm or cold?

  4. #4
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    no its worse once it gets warmed up. like ill be in 5th gear only doing like 45-50 which is below 2000rpm ill push in the clutch and it will actually idle higher above 2000 and just sit there while im coasting.

  5. #5
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    how do you do an idle relearn by the way?

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    your idle issues could be tune related. You did heads/cam with a mail order starter tune right? Tune might just need to be dialed in. Can you post the actual codes you're getting for the O2's?

  7. #7
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    i think the codes were p0134 and p0154 both 02 sensors and p0507 i think for high idle

  8. #8
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    the 134 and 154 codes are good signs of bad sensors. Like I said, replace the sensors and do the idle relearn:

    Automatic Transmission:



    1 Turn off the ignition

    2 Restore the PCM battery feed

    3 Turn Off the AC controls

    4 Set the parking brake and block the drive wheels

    5 Start the engine

    6 Allow the engine coolant temperature to reach 176 degrees F

    7 Shift the transmission selector into the drive range

    8 Allow the engine to idle for 5 minutes

    9 Turn on the AC controls (Omit for 2000-02 model)

    10 Allow the engine to idle for 5 minutes (Omit for 2000-02 model)

    11 Shift the transmission selector into Park

    12 Allow the engine to idle for 5 minutes (Omit for 2000-02 model)

    13 Turn off the AC controls (Omit for 2000-02 model)

    14 Allow the engine to idle for 5 minutes

    15 Turn off the engine for 15 seconds



    Manual Transmission:



    1 Turn Off the ignition

    2 Restore the PCM battery feed

    3 Turn Off the AC controls

    4 Set the parking brake and block the drive wheels

    5 Transmission in neutral

    6 Start the engine

    7 Allow the engine coolant temperature to reach 176 degrees F

    8 Turn on the AC controls (Omit for 2000-02 model)

    9 Allow the engine to idle for 5 minutes (Omit for 2000-02 model)

    10 Turn off the AC controls (Omit for 2000-02 model)

    11 Allow the engine to idle for 5 minutes

    12 Turn off the engine for 15 seconds

  9. #9
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    where at in Ohio are you? I have efilive I can hook up to your car and we could work on your tune.

  10. #10
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    i live in mansfield. i changed out the 2 o2 sensors but the ses light is still on. i have to go to autozone and see if its still same codes

  11. #11
    MANWHORE TEAM suede's Avatar
    Join Date
    Apr 2007
    Location
    Your Mom's Bedroom
    Posts
    4,548

    Negro
    2000 Trans Am WS.6

    yea you will need them cleared first to see if they trip again...

  12. #12
    Junior Member
    Join Date
    Apr 2009
    Location
    Chesapeake, Va
    Age
    26
    Posts
    3

    White
    1998 Z28

    idle and o2s

    what is the stock idle set at for manual transmissions from factory? isnt it diff from the automatics?

  13. #13
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Quote Originally Posted by jmatt07 View Post
    i live in mansfield. i changed out the 2 o2 sensors but the ses light is still on. i have to go to autozone and see if its still same codes
    Or reset the PCM and do the idle relearn.

  14. #14
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    just to make sure......to reset the pcm i just unhook the negative from the battery for like 15 min right?

  15. #15
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Or a short cut:
    Ign switch to on, engine off
    Pull the PCM fuse
    Ign Switch to off
    Replace the PCM fuse

    Start the car and do the idle relearn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Idling
    By edrvsqz1980 in forum Firebird / WS6
    Replies: 27
    Last Post: 07-22-2010, 03:15 AM
  2. Idling RPM's?
    By qwk01ta in forum General Help
    Replies: 3
    Last Post: 04-27-2010, 11:09 PM
  3. idling problems
    By sweet ss in forum General Help
    Replies: 0
    Last Post: 10-16-2007, 10:27 AM
  4. My Camaro idling
    By Kamauxx in forum Camaro / SS
    Replies: 4
    Last Post: 10-05-2007, 06:46 PM
  5. Idling at 650 to 750 RPM's
    By 9t8z28 in forum External Engine
    Replies: 4
    Last Post: 10-31-2006, 07:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •