View Poll Results: Which antifreeze Do You Use?

Voters
87. You may not vote on this poll
  • Prestone antifreeze

    12 13.79%
  • DexCool

    65 74.71%
  • Other

    10 11.49%
Page 1 of 3 123 LastLast
Results 1 to 20 of 41

Which Do You Use?

This is a discussion on Which Do You Use? within the General Help forums, part of the LSx Technical Help Section category; Which antifreeze do you use in your ride? -Prestone antifreeze or DexCool? And what additives do you use for your ...

  1. #1
    weberje
    Guest

    Which Do You Use?

    Which antifreeze do you use in your ride?

    -Prestone antifreeze or DexCool?


    And what additives do you use for your radiator? I've heard good things about royal purple- purple Ice. Any takers?


  2. #2
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    69
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    50/50 mix Dexcool
    Flushed once a year
    126K on the clock had 0 when I bought it

  3. #3
    Nitrous Tuner LS2Tuner's Avatar
    Join Date
    Aug 2006
    Location
    WestCoast AZ-CALI
    Posts
    4,763

    Silver
    05 Goat SMASHED

    DexCool can become VERY corrosive!!!!! Unless your dealing with warr. issues we ALWAYS get rid of that stuff!!!!
    Don't be afraid of the bottle!!! Be afraid of your tune!!!

  4. #4
    i make cars slower s99ta's Avatar
    Join Date
    Nov 2006
    Location
    Iowa
    Posts
    119

    black
    1999 trans am

    Quote Originally Posted by LS2Tuner View Post
    DexCool can become VERY corrosive!!!!! Unless your dealing with warr. issues we ALWAYS get rid of that stuff!!!!
    I second that!!

  5. #5
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    i've always had the green in my car. is that bad?

  6. #6
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    honestly when i bought em, they both had the green. never thought to ask the previous owners about it.

  7. #7
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    sweet. its been doing fine anyway. also, it runs pretty cold. between the first and second mark on the temp gauge.

  8. #8
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    97 trans am A4 almost 93000 miles.

  9. #9
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    sorry, 5.7 LT1

  10. #10
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    i'll have to post a pic for you sometime of my temp gauge. it seems extremely low.....but it works.

  11. #11
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    runs cooler than that. right exactly between the first and second mark.

  12. #12
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    well, the fans dont come on for one thing. the AC fan does. but thats it.

  13. #13
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    two years as of november 16

  14. #14
    Awaiting Activation Liquifire's Avatar
    Join Date
    Aug 2005
    Location
    central wisconsin
    Age
    39
    Posts
    702
    Or Someone Could Have Put In A Cooler 'stat

  15. #15
    Homebrew Master irishpenguin13's Avatar
    Join Date
    Aug 2006
    Location
    leesburg, florida
    Age
    36
    Posts
    572

    Arctic White
    1997 Trans Am

    not sure. im gonna hafta say no. last two owners were an old lady and an old man.

  16. #16
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    The only times I have seen DexCool issues is when there was a leak or somebody tried to run it for a billion miles. If your cooling system/cap is maintaining pressure and your flushing it and replacing it once a year....you'll never have an issue. And never mix DexCool with anything else.
    This is my signature. It is mine. Nobody else has one like it.

  17. #17
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    dex all the way

  18. #18
    Nitrous Tuner LS2Tuner's Avatar
    Join Date
    Aug 2006
    Location
    WestCoast AZ-CALI
    Posts
    4,763

    Silver
    05 Goat SMASHED

    Quote Originally Posted by s99ta View Post
    I second that!!
    If you don't put there stupid tabblets in;that shit eats aluminum like NO tomorrow!!! We have got some VERY high voltage readings out of some customers cars coolant before we changed it out. If your running "orange" try it. Take a multimeter and ground one probe and put the other in the coolant and see what you get.
    But thats how they can tell real quick on a warr. issue weather or not it has recieved it required services. They do everything for a reason!

    The first thing to get flushed and changed in anything I drive.
    Including the 05 Goat with a $550 Mazier pump. http://www.jegs.com/webapp/wcs/store...53453_-1_10135
    It keeps it cooler than the stock pump even in the heat out here!

  19. #19
    Junior Member
    Join Date
    Jan 2007
    Location
    chiefland florida
    Posts
    21

    red
    98 transam

    green stuff changed to meany intake gaskets becase of dexcool

  20. #20
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Quote Originally Posted by limey62 View Post
    green stuff changed to meany intake gaskets becase of dexcool
    Please elaborate. Faulty intake gaskets are not because of Dexcool, just poor design. If you notice, the most GM engines with that problem are the 3.1/3.4 V6s. And, if Dexcool is the problem, what about the Olds 307 V8 engines from the 80s? I have changed so many of those intake gaskets back in the day I am almost rich from that.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •