Page 2 of 2 FirstFirst 12
Results 21 to 30 of 30

Dirty coolant..

This is a discussion on Dirty coolant.. within the General Help forums, part of the LSx Technical Help Section category; Originally Posted by M-Ten yeah i guess i'll have it flushed and i'll have the oil changed tomorrow too.. it's ...

  1. #21
    Senior Member splitfinger09's Avatar
    Join Date
    May 2007
    Location
    Bartlesville, Oklahoma, United
    Age
    30
    Posts
    1,264

    Bright Rally Red
    2000 Camaro SS #5075 M6

    Quote Originally Posted by M-Ten View Post
    yeah i guess i'll have it flushed and i'll have the oil changed tomorrow too.. it's throwing a few codes.. i read them in the book but i don't know what it means or how to fix it.
    If you have the proper tools you can def change the oil yourself. Its no very hard, take you 30-45min tops.

  2. #22
    Senior Member M-Ten's Avatar
    Join Date
    Jun 2007
    Location
    St. Pete, Florida
    Age
    27
    Posts
    2,210

    Silver+Black/Black+Silver
    1999 TA M6/03 GSXR 600

    It's a 99. And no the temp guage is not moving at all, it's all the way down at the bottom, I think it's 100. Either way it's not moving at all it's just staying there the whole time. But no I'm not having any idling issues, and yes the car is completely stock.. I am going to take a look at it tomorrow and try to figure it out, I'll also check in the owner's manual and see if I can find anything..

  3. #23
    Ricekiller z28punk's Avatar
    Join Date
    Nov 2006
    Location
    Maple Grove, MN
    Age
    29
    Posts
    509

    Pewter
    2002 Camaro Z28

    just get the dex-clog crap out of there. Switch to green or yellow and u will be fine.

    take the A.I.R. system out of there. its a waste of space.

  4. #24
    Senior Member M-Ten's Avatar
    Join Date
    Jun 2007
    Location
    St. Pete, Florida
    Age
    27
    Posts
    2,210

    Silver+Black/Black+Silver
    1999 TA M6/03 GSXR 600

    it says to use the dex cool and nothing else..? and what does the air system do?

  5. #25
    Member camaross19973's Avatar
    Join Date
    Mar 2007
    Location
    Los Angeles
    Age
    44
    Posts
    238

    blue
    1999 camaro ss #976

    by the way while ur at it, chk ur powersteering fluid if that is dirty u need to change the the power steering cooler. its a long tube that runs in the midle of the air fans u know what it is when u see it ,

  6. #26
    Senior Member M-Ten's Avatar
    Join Date
    Jun 2007
    Location
    St. Pete, Florida
    Age
    27
    Posts
    2,210

    Silver+Black/Black+Silver
    1999 TA M6/03 GSXR 600

    oh ok thanks, what color is it normally?

  7. #27
    I have a need for speed! jigger1166's Avatar
    Join Date
    Dec 2006
    Location
    Standish,Maine
    Age
    51
    Posts
    560

    Artic White
    00 SS Vert.

    Quote Originally Posted by M-Ten View Post
    It's a 99. And no the temp guage is not moving at all, it's all the way down at the bottom, I think it's 100. Either way it's not moving at all it's just staying there the whole time. But no I'm not having any idling issues, and yes the car is completely stock.. I am going to take a look at it tomorrow and try to figure it out, I'll also check in the owner's manual and see if I can find anything..
    It sounds like there's a prob. with the temp. gauge.
    Plug a scan tool in, and check the data to see what the ECT reading is. If it shows an increase after running for a while, your gauge is bad.
    JIGGER RACIN'
    2000 Camaro SS, vert., auto., LS6 intake manifold, SLP lid, K&N filter, SLP LoudMouth II, C5 Z06 replica 17x9.5 rims
    1/4 mile time = 13.310 sec. @ 105.22 mph, 2.051 60'

    http://www.cardomain.com/ride/2939958

    http://i158.photobucket.com/albums/t...amarolaeft.jpg

  8. #28
    Senior Member M-Ten's Avatar
    Join Date
    Jun 2007
    Location
    St. Pete, Florida
    Age
    27
    Posts
    2,210

    Silver+Black/Black+Silver
    1999 TA M6/03 GSXR 600

    yeah well i check the codes and it's saying Temp Gage Data Out Of Range.

    I just replaced one of the sensors and it didnt' affect it at all.. the gage is stayin at 110 degrees still and not moving..

    Is there another sensor that might need to be replaced?

  9. #29
    I have a need for speed! jigger1166's Avatar
    Join Date
    Dec 2006
    Location
    Standish,Maine
    Age
    51
    Posts
    560

    Artic White
    00 SS Vert.

    Quote Originally Posted by M-Ten View Post
    yeah well i check the codes and it's saying Temp Gage Data Out Of Range.

    I just replaced one of the sensors and it didnt' affect it at all.. the gage is stayin at 110 degrees still and not moving..

    Is there another sensor that might need to be replaced?
    Sometimes there's a sensor that controls the gauge, and sends data to the PCM, and then there's a switch that turns on the idiot light. Did you replace the right one?
    Or maybe the gauge is bad.

  10. #30
    Senior Member M-Ten's Avatar
    Join Date
    Jun 2007
    Location
    St. Pete, Florida
    Age
    27
    Posts
    2,210

    Silver+Black/Black+Silver
    1999 TA M6/03 GSXR 600

    yeah i replaced the driver side one above cylinder head 1

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NY 25th congressional election dirty dirty dirty
    By krese in forum Political / Debate Forum
    Replies: 6
    Last Post: 11-12-2010, 04:07 AM
  2. Help: Need pic of coolant pump weep hole (Coolant Leak)
    By Sweet Chops in forum General Help
    Replies: 13
    Last Post: 04-20-2009, 08:14 PM
  3. Replies: 23
    Last Post: 06-19-2007, 08:28 AM
  4. Coolant light...coolant level full.
    By SR71 in forum General Help
    Replies: 4
    Last Post: 01-08-2007, 10:35 AM
  5. ls6 intake coolant plugs or extra front coolant pipe?
    By mikes ss in forum External Engine
    Replies: 3
    Last Post: 12-03-2005, 05:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •