Results 1 to 8 of 8

Dead gauges, odometer and doesn't turn over...

This is a discussion on Dead gauges, odometer and doesn't turn over... within the General Help forums, part of the LSx Technical Help Section category; Ok, here's the break down... Car had been driven all day in rain. Had time to dry out before rewashing. ...

  1. #1
    Member bhunter0830's Avatar
    Join Date
    Apr 2012
    Location
    Fishers (Indianapols), IN
    Posts
    475
    On the hunt

    Dead gauges, odometer and doesn't turn over...



    Ok, here's the break down...

    Car had been driven all day in rain. Had time to dry out before rewashing. On the way out the gas peddle went hard. Had to shut down and restart. Gas peddle worked fine again. The car had not gotten wet again before the gauges died and the odometer died. I continued through the wash and shut it down. No gauges, odometer & no turn over. Had the fog lamps on when this happened, left turn signal stayed on the dash when this happened. Turned lights off, turn signal goes off on dash. No Security Light's staying on. Radio, windows, wipers, seats, dome lights etc still work.

    1. Battery tested good.
    2. Starter tested good. (Replaced as it was off car and original one)
    3. Alternator tested good.
    4. Traced wires to all with good voltage.
    5. No voltage to "exciter wire" on starter when key turned.
    6. PCM pulled but not sure why... Now put back in.
    7. Grounded PCM to battery... No change

    Question 1: Would the ignition switch (located under dash on stearin column) were to go bad, would that also control the dash and odometer to also not work?

    Question 2: If I can get the starter to spin and start the engine using a different battery to start the car running, and the gauges don't work, would it be safe to say that it's the ignition (Depending on the answer to question 1). Or would that mean it's the PCM or BCM?

    At this point I am entirely lost and am 1 day away from having it towed to have someone else figure it out...

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Swap out the starter relay and check all fuses in the underhood electrical boxes. Does the fuel pump come on when you turn the key?

  3. #3
    Member bhunter0830's Avatar
    Join Date
    Apr 2012
    Location
    Fishers (Indianapols), IN
    Posts
    475
    On the hunt

    Quote Originally Posted by pajeff02 View Post
    Swap out the starter relay and check all fuses in the underhood electrical boxes. Does the fuel pump come on when you turn the key?
    I have swapped the starter relay and even replaced them as well. The fuel pump does turn on when the key is turned. I have also tested all the fuses under the hood and in the car. Thanks Jeff! Any other thoughts?

  4. #4
    Member bhunter0830's Avatar
    Join Date
    Apr 2012
    Location
    Fishers (Indianapols), IN
    Posts
    475
    On the hunt

    Quote Originally Posted by pajeff02 View Post
    Swap out the starter relay and check all fuses in the underhood electrical boxes. Does the fuel pump come on when you turn the key?
    Would that cause the gauges and odometer not to turn on?

  5. #5
    Member bhunter0830's Avatar
    Join Date
    Apr 2012
    Location
    Fishers (Indianapols), IN
    Posts
    475
    On the hunt

    I am afraid I will have to admit defeat... It'll towed to someone who can troubleshoot further than I without causing more issues... Thanks to all that have helped to contribute!

  6. #6
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Was it pouring out when you were driving? Did you drive through any floods? Almost sounds like you shorted an exposed wire beneath the front of the car.

  7. #7
    Member bhunter0830's Avatar
    Join Date
    Apr 2012
    Location
    Fishers (Indianapols), IN
    Posts
    475
    On the hunt

    It was pouring however, it was traced to a pinched wire and blown fuse... Thanks!

  8. #8
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Okay. Good to hear.


    extreme dimensions, driveshaft shop, harrop, hid(35watt/6k) lows, hurst, k&n, led fogs, maverick man, mishimoto, nitto, revshift, slp, stern st-1, smoked sidemarkers, whiteline poly radius rod bushings

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Let's hope this doesn't turn into another Mogadishu
    By SiggyZ in forum Political / Debate Forum
    Replies: 0
    Last Post: 10-14-2011, 01:54 PM
  2. Problem With Odometer & Turn Signal
    By Black Roc in forum General Help
    Replies: 9
    Last Post: 02-09-2010, 05:00 PM
  3. turn signal doesn't blink but the light comes on
    By ajonesz28 in forum Camaro / SS
    Replies: 20
    Last Post: 03-23-2009, 04:02 PM
  4. Car Wont Start, When Jumoped Gauges turn off + On?
    By Patsy57 in forum Stereo and Electronics
    Replies: 3
    Last Post: 04-11-2008, 12:26 PM
  5. Phantom Gauges,white Gauges(lt1),gauge Pod
    By onefastbird! in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 11-19-2006, 04:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •