Results 1 to 7 of 7

Dam codes

This is a discussion on Dam codes within the General Help forums, part of the LSx Technical Help Section category; Hey guys, well i finally decided to see what was up with my SES light. So i took it down ...

  1. #1
    Senior Member rajiv1998's Avatar
    Join Date
    Sep 2006
    Location
    New Jersey
    Age
    30
    Posts
    1,489

    Black
    1998 Pontiac Trans Am

    Dam codes

    Hey guys, well i finally decided to see what was up with my SES light. So i took it down to a shop and have them read the codes for free. I wrote it down on paper, but the sheet is in my car, ill get it later but one of the codes said "Catalysit efficiancy low bank 2" and the other was a "Random misfire" I dont know whats up?? The engine runs strong and pulls hard, but wuts up with the codes. During startup, the idle is kinda choppy. I was thinking i MIGHT have a mild aftermarket cam in the car? The cats are fine, and i just replaced my 02 sensors about a month or two ago so idk wuts wrong?? I dont wanna tear open the motor to see if its a stock cam, but is there another alternative? Any help??

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    it'd be nice to see what the codes were. Cat code could be from bad cats. Random misfire could be a few things. There really is no way of knowing what cam you have other than tearing it down. No way to contact the previous owner?

  3. #3
    Senior Member rajiv1998's Avatar
    Join Date
    Sep 2006
    Location
    New Jersey
    Age
    30
    Posts
    1,489

    Black
    1998 Pontiac Trans Am

    ill post up the codes tommorow. I was actually just in the car but forgot. During the first few seconds of startup, u can clearly hear a chop, and i know its not the idle thats fucked up. I dont think i have the owners phone #, but his name was "Mike". Also, i think the car has the WS6 suspension kit. I have seen a few WS6's with the same springs that were on my car, but im not 100% sure.

  4. #4
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Take it to a tuner and get those codes turned off. Then enjoy the car. Maybe pull the valve covers and see what kind of springs are on it? I would.

  5. #5
    Cookie Monster LukesSpeedShop's Avatar
    Join Date
    Apr 2007
    Location
    Watertown, New York
    Age
    31
    Posts
    126

    Navy Blue Metallic
    2002 Z28

    Choppy idle during startup could definatly be from your misfire there. Random misfire could be one or more or many reasons.... And a catalyst inefficency bank 2 could be from either a bad cat, carbon build-up, or an exhaust leak, Im assuming your code is P0420

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Bank 2 is the passenger side, so the cat code would be P0430. I was thinking to suggest swapping the rear 02 sensors from bank to bank to verify if it's the cat, but you said you already replaced them.

  7. #7
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    I had a misfire code and found out the number 8 plug had never been changed. Basically I had a dead cylinder. misfire code would be p0300-p0308( 300 being random and 301 302 etc etc for each matching cylinder) Makes a world of difference just doing a tuneup. As for the cat codes 0420 p0430.

    code P0420 may mean that one or more of the following has happened:

    Leaded fuel was used where unleaded was called for
    An oxygen sensor is not reading (functioning) properly
    The engine coolant temperature sensor is not working properly
    Damaged exhaust manifold / catalytic converter / exhaust pipe
    Retarded spark timing


    A code P0430 may mean that one or more of the following has happened:

    The catalytic converter is no longer functioning properly
    An oxygen sensor is not reading (functioning) properly
    There is an exhaust leak

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what do these codes mean
    By jb007 in forum General Help
    Replies: 0
    Last Post: 05-19-2010, 07:32 PM
  2. codes
    By camaro00ss in forum General Help
    Replies: 5
    Last Post: 03-31-2008, 11:14 AM
  3. no RPO codes
    By deepblackz in forum Camaro / SS
    Replies: 4
    Last Post: 11-06-2007, 08:56 AM
  4. What do these codes mean. PLEASE HELP
    By ram air ws6 in forum General Help
    Replies: 5
    Last Post: 02-23-2007, 06:34 PM
  5. New and I need some help with SES codes.
    By mczerwonka in forum General Help
    Replies: 3
    Last Post: 01-28-2007, 08:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •