Results 1 to 4 of 4

Cruise control stopped working???

This is a discussion on Cruise control stopped working??? within the General Help forums, part of the LSx Technical Help Section category; cruise just decided to stop working. i checked the fuse panel and i don't know if there is a certain ...

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    Cruise control stopped working???

    cruise just decided to stop working. i checked the fuse panel and i don't know if there is a certain fuse that corresponds to cruise. can someone help me out? i don't even know whats wrong, it just doesn't work at all.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    I dont remember off hand but im pretty sure there is a fuse for the cruise. Also pop the hood and take a look at the linkage to ensure its still connected.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Check your brake light switch down on the brake pedal and make sure it's adjusted properly.

    If you have a 6speed then also check the clutch pedal switch as well while you're under there. Make sure it's adjusted and depressed fully when the clutch pedal is all the way up.

    Both of these switches must be operational for cruise to engage.

    My cruise didn't work on a car I just recently purchased. I crawled under the dash and found the clutch pedal switch completely adjusted out and away from the pedal, not making contact at all. Don't know why,,,,but once I adjusted it properly the cruise works flawless now.

    This may not be your problem but it's one of a few things to check.

    The multifunction switches (turnsignal/wiper/cruise) are also notorious for going out. There is a very easy diagnostic procedure to follow in the GM manual for this,,,,and thats probably the best thing to do if you don't know where to start. Hope that helps. Larry.

  4. #4
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    +1, check brake and clutch switches...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: HELP!!! ABS and ASR Stopped Working!!!
    By NastySS in forum General Help
    Replies: 23
    Last Post: 06-14-2012, 06:52 AM
  2. Help: My A/C stopped working WHILE DRIVING.....HELP!!!
    By NastySS in forum General Help
    Replies: 25
    Last Post: 06-13-2012, 05:45 PM
  3. Clutch Replaced-->Now Cruise Control Not Working
    By 120inna55 in forum General Help
    Replies: 5
    Last Post: 02-23-2012, 12:35 PM
  4. All my seatbelts stopped working, WTF??
    By UKRAMAIR in forum General Help
    Replies: 3
    Last Post: 08-30-2009, 09:49 AM
  5. Help: msd opti stopped working?
    By RollingD in forum Firebird / WS6
    Replies: 0
    Last Post: 05-09-2009, 12:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •