Results 1 to 8 of 8

Couple of Problems

This is a discussion on Couple of Problems within the General Help forums, part of the LSx Technical Help Section category; About 3 years ago, almost exactly, I replaced the fuel pump in my car. Yesterday, my car started up, rumbled, ...

  1. #1
    Member LgndKller20073's Avatar
    Join Date
    Jul 2007
    Location
    Denver,CO
    Age
    28
    Posts
    455

    Arctic White
    2001 Firebird

    Couple of Problems

    About 3 years ago, almost exactly, I replaced the fuel pump in my car. Yesterday, my car started up, rumbled, then died like it was out of gas. I was running low, but not out. I had somebody take me to the gas station, and put in like 5 gallons of gas. The car would turn over, but still not run. Finally, after another 2 gallons of gas, I got it started, however pressing on the gas pedal literally does nothing. It almost causes backfire. I have a feeling that I need to replace my fuel pump again. I ordered one off eBay so it should be here next week. Just curious on if you guys think I'm on the right track for this?

    Next problem. I've bypassed my VATS, but sometimes I'll put the key into the ignition and the security light will show up and I can't start my car. I pulled the resistor out and it's still running at a constant resistance equivalent to my key. I'm unsure of why it would be doing this. Anybody else had this problem?

    Finally, I think I need to replace my window motors. The driver side will sometimes go up and down no problem and other times it will go up a little and completely stop then a few minutes later will start to go up and stop again. The passenger side is super slow going up and down. Anybody else have some tricks or comments on making the replacement a little easier. I've read about replacing them and some people say it's fairly easy and others say it's a PITA.

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    1) It could be several things, check fuel filter 1st. clogged = no running. Fuel pump, did you instal it or someone else? If you can get a pressure reading from the rails post it. Should be around 56psi @ idle. Hope running low didn't suck trash up into the filter.


    3) Autotrix sells a a relay mod that is the best $38 you can spend. Fixes the cause of what kills the passenger motor. Takes an hr to do. Google "Autotrix passenger window fix". I can't post because they are not a vendor. Been using it for 2 yrs now and no issues. Replacing a motor is PITA but no to difficult.

    Here's a how to that is spot on.
    Power Window Motor

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    +1 Check the filter and pressure at the rail before you go at another pump relacement.

  4. #4
    Member LgndKller20073's Avatar
    Join Date
    Jul 2007
    Location
    Denver,CO
    Age
    28
    Posts
    455

    Arctic White
    2001 Firebird

    The fuel filter looked fine. I honestly think the pump was going. My gas guage stopped working on my dash like a year ago so I'd just go by mileage for when I needed to fill up. And I was getting surges of power every now and then to the engine. I'd be going along at 55-65mph and my RPM's would rise a little like I had just pressed the gas. I think it was coming and running low on gas finally killed it. I could be wrong though. It was idling pretty rough yesterday, like <1,000 RPM. It usually idles around 1,200 and I could get it to start and sometimes it would start for a few seconds and die. I just don't think it's getting fuel. Replacing the pump is fairly easy for me now since I did the trap door method the first time. It would take about 15 minutes in all to replace.
    Last edited by LgndKller20073; 08-09-2013 at 10:44 AM.

  5. #5
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    How much did you pay for the pump?

  6. #6
    Member LgndKller20073's Avatar
    Join Date
    Jul 2007
    Location
    Denver,CO
    Age
    28
    Posts
    455

    Arctic White
    2001 Firebird

    I paid $400 for the Airtex pump from autozone 3 years ago. I found the same thing on eBay this time around for $69.70

  7. #7
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Most of get the Racetronix pump for around $160 and be done with it.

  8. #8
    Member LgndKller20073's Avatar
    Join Date
    Jul 2007
    Location
    Denver,CO
    Age
    28
    Posts
    455

    Arctic White
    2001 Firebird

    I looked at the Racetronix I think when I first had fuel pump problems 3 years ago. I have the V6 though and I thought they only had then for the V8

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ok so a couple of problems..
    By Ws6islife in forum Firebird / WS6
    Replies: 1
    Last Post: 10-15-2009, 09:52 PM
  2. A couple ?s about RX8's
    By 01ls1ws6 in forum Almost Anything Goes
    Replies: 11
    Last Post: 04-20-2009, 03:10 AM
  3. a couple problems
    By transamdude99 in forum Firebird / WS6
    Replies: 4
    Last Post: 12-03-2008, 08:48 AM
  4. Couple of ? for you all.
    By transam98 in forum Internal Engine
    Replies: 4
    Last Post: 11-28-2007, 06:24 PM
  5. couple Q's
    By NxLS1496 in forum Camaro / SS
    Replies: 13
    Last Post: 12-10-2005, 02:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •