Results 1 to 4 of 4

Coolant Sensor

This is a discussion on Coolant Sensor within the General Help forums, part of the LSx Technical Help Section category; I think it's crapped out on my '94 Z28 . I put plent of coolant in it a month ago, ...

  1. #1
    Member
    Join Date
    Feb 2006
    Age
    29
    Posts
    106

    Coolant Sensor

    I think it's crapped out on my '94 Z28 . I put plent of coolant in it a month ago, and have checked it every 3 days since for leaks or problems, and the only problem I can find is that in the morning, whether its cold or warm the light automatically kicks on. Once I get to work and turn the car off, and then restart it, the light goes away until the next morning. Sooo, what I have to ask is:

    1. Is a Chevy dealer the only place to pick up a new one of these?
    2. What kind of pricing do they run?
    3. Is the process to replace the sensor tough? And if not, how do i do it?

    Thank you!!

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    There not hard to replace, and go bad all the time. Have you checked the coolant level in the radiator when the car is cold? http://shbox.com/1/low_coolant.jpg

  3. #3
    Member SR71's Avatar
    Join Date
    Nov 2005
    Location
    Irving, TX
    Age
    36
    Posts
    105

    Black
    1998 Trans Am, 2007 TB SS

    you can get a replacement at napa, advanced auto, or any place like that. they usually run 20 or 30 bucks. Mine crapped out about 3 months ago and I just unhooked it. wont hurt anything at all as long as you check your levels on the regular. some people take them off and clean them and put them back on and that helps for a while. go to your radiator and it should be about three or four inches down below the cap. you cant miss it. Hope this helps.

  4. #4
    Member
    Join Date
    Feb 2006
    Age
    29
    Posts
    106
    hell, looks easy enough. thanks ya'll !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help troubleshooting a problem!
    By jrbonds in forum LT1
    Replies: 17
    Last Post: 01-28-2007, 05:32 PM
  2. Help!! Coolant leak but where?
    By jinxeng in forum General Help
    Replies: 6
    Last Post: 09-07-2006, 11:30 PM
  3. The O2 Sensor Problem That Doesn't Go Away!!!
    By jdubbs928 in forum General Help
    Replies: 6
    Last Post: 07-31-2006, 05:11 PM
  4. Coolant Temperature Sensor
    By ERICV82GO in forum External Engine
    Replies: 2
    Last Post: 07-07-2006, 07:43 PM
  5. motor hesitates aroung 2500rpm
    By Garry in forum Internal Engine
    Replies: 25
    Last Post: 06-19-2006, 08:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •