Results 1 to 7 of 7

complete ls1 swap blogs and sites?

This is a discussion on complete ls1 swap blogs and sites? within the General Help forums, part of the LSx Technical Help Section category; Hi, Im new to this site and am in the process of doing a ground up restore of a 67 ...

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Location
    St Cloud, MN
    Posts
    2

    unknown
    1967 firebird

    complete ls1 swap blogs and sites?

    Hi,
    Im new to this site and am in the process of doing a ground up restore of a 67 firbird. I am looking for sites and info from others who have taken on this type of project. this link is the type of site I am looking for, although this one if for a 3rd gen swap, it is the type of thing Im looking for

    http://www.thirdgen.org/techboard/lt...on-answer.html

    Any help would be much apreciated!!
    Thanks

  2. #2
    Junior Member
    Join Date
    Dec 2009
    Location
    Calgary, Canada
    Posts
    22

    Silver
    87 Monte SS

    You may have to piece together any swap info you can find for any type of car, and figure out the rest. I swapped an LS1 into my 87 Monte SS myself almost 2 years ago, and there wasn't as much information back then. Although I'm a certified mechanic, which helps quite a bit. I also used to work at a forced induction specialty shop and became quite familiar with the LSX series engines. I'm happy to help you in anyway I can, don't hesitate to ask. I've also built a few small and big block first gen F bodies, and am familiar with them too. It's not nearly as difficult of a project as it seems.

  3. #3
    Junior Member
    Join Date
    Dec 2009
    Location
    Calgary, Canada
    Posts
    22

    Silver
    87 Monte SS

    Also you can see my car here if you'd like. Keep in mind it's daily driven, so it's dirty.

  4. #4
    Member crossbredfoxbody's Avatar
    Join Date
    Jan 2010
    Location
    First In Flight
    Age
    35
    Posts
    160

    white
    83 mustang coupe

    Is this build for racing or driving?

  5. #5
    Junior Member
    Join Date
    Dec 2009
    Location
    St Cloud, MN
    Posts
    2

    unknown
    1967 firebird

    Quote Originally Posted by crossbredfoxbody View Post
    Is this build for racing or driving?
    My plan is to build a 350, 400 hp driver

  6. #6
    Junior Member
    Join Date
    Apr 2012
    Location
    phoenix AZ
    Posts
    5

    grey
    1986 Camaro

    Okay so i have a 1986 Camaro and threw in a ls1 but cant get to fire it up, seems that the injectors don't have any negative running to the them, and i flashed the computer and i am using the original wire harness, just took all the extra wires i didn't need. is it that the computer is not flashed right, or which wires are the one's that send the negative and positive charges to the injectors that i would be able to check...?

  7. #7
    Junior Member
    Join Date
    Dec 2009
    Location
    Calgary, Canada
    Posts
    22

    Silver
    87 Monte SS

    Quote Originally Posted by ls1irocz View Post
    Okay so i have a 1986 Camaro and threw in a ls1 but cant get to fire it up, seems that the injectors don't have any negative running to the them, and i flashed the computer and i am using the original wire harness, just took all the extra wires i didn't need. is it that the computer is not flashed right, or which wires are the one's that send the negative and positive charges to the injectors that i would be able to check...?
    One of the wires at each injector will have +12V constant with the key in the run position, and the computer momentarily grounds the other each time it wants to fire an injector, so you will only get ground there when the engine is cranking or running, and it's very short pulses, if you are using a standard test light, it might be too fast for the bulb to light up, you need to use an LED test light, and what I like to do is to run the probe of the test light into one terminal, and the lead clipped onto a cotter pin or something small and stuck in the other terminal, then when you crank the engine you should see the LED flashing very quickly. If you are getting spark, but not injector pulse, and all your wiring is good then your computer is faulty, the computer will always spark and fire injectors together, if you aren't getting either, then the computer is faulty, or isn't turning on, or is unaware that the engine is turning, and you may have an issue with the crankshaft position sensor or circuit. Make sure all your powers and grounds to your computer are good, there are multiple powers and grounds to it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB: LS1 w/ T56 complete swap
    By a32guy in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 06-28-2007, 11:29 PM
  2. WTB LS1 complete swap....
    By floggin in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 03-21-2007, 11:42 AM
  3. FS: Complete T56 swap
    By Chevythunder17 in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 03-20-2007, 05:28 PM
  4. WTB: complete LS1/T56 swap
    By anyotherone in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 07-08-2006, 12:40 PM
  5. wtb: COMPLETE m6 T56 swap for LT1 Z28
    By 2000blkTA in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 04-21-2006, 12:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •