Results 1 to 8 of 8

Coil Problems

This is a discussion on Coil Problems within the General Help forums, part of the LSx Technical Help Section category; I am wondering if it is possible for the coils on my 98 Z28 to miss at idle but function ...

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Location
    Charlotte NC
    Posts
    62

    NBM
    1998 Z28

    Question Coil Problems

    I am wondering if it is possible for the coils on my 98 Z28 to miss at idle but function properly under load? The car runs fine but when I'm sitting in Park or stopped at a light it sounds and feels like I'm getting an intermittent miss.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Small possiblity buy not likely. Do you have a SES light that might point at which cylinder is misfiring?

  3. #3
    Junior Member
    Join Date
    Jan 2010
    Location
    Charlotte NC
    Posts
    62

    NBM
    1998 Z28

    No SES light just a slight miss at idle.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    most likely culprit is your MAF needs cleaning.


    Are you running a K&N filter?


    2nd most likely culprit is a vacuum leak. Check your PCV tubing around the PCV & also around the back side behind the intake where it splits into a Y. Those are the two common spots for vacuum leaks to develop.


    recheck you plug wires. one click plug, 2 clicks the coil.

  5. #5
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Clean your MAF sensor and put some fuel system cleaner in the tank and see if the miss goes away. Also, check your intake bellows at the throttlebody to see if there are any holes in it.

  6. #6
    Junior Member
    Join Date
    Jan 2010
    Location
    Charlotte NC
    Posts
    62

    NBM
    1998 Z28

    I will check the bellows in the morning. thanx.

  7. #7
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by SMWS6TA View Post
    most likely culprit is your MAF needs cleaning.


    Are you running a K&N filter?


    2nd most likely culprit is a vacuum leak. Check your PCV tubing around the PCV & also around the back side behind the intake where it splits into a Y. Those are the two common spots for vacuum leaks to develop.


    recheck you plug wires. one click plug, 2 clicks the coil.

    Correction - 2 clicks at the plug, one at the coil.

  8. #8
    Junior Member
    Join Date
    Jan 2010
    Location
    Charlotte NC
    Posts
    62

    NBM
    1998 Z28

    2 clicks at the plug....Hmmmm..interesting, i will check thanx.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wanted: SIR Coil
    By MrKid in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 07-27-2010, 06:51 AM
  2. Question: LS1 coil help
    By wmr71 in forum General Help
    Replies: 2
    Last Post: 07-25-2008, 10:08 PM
  3. Stock front coil springs off 98' SS with 1/2 coil removed
    By KIXASS in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 07-31-2007, 07:57 AM
  4. Truck coil to replace the OEM coil
    By fc227 in forum General Help
    Replies: 6
    Last Post: 11-18-2006, 09:57 PM
  5. Coil choices
    By AF1Bird in forum General Help
    Replies: 4
    Last Post: 03-20-2006, 08:36 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •