Page 3 of 3 FirstFirst 123
Results 41 to 43 of 43

Clutch pedal problem

This is a discussion on Clutch pedal problem within the General Help forums, part of the LSx Technical Help Section category; System works pretty simply: When you press the pedal, the master cylinder sends fluid to the slave cylinder. As the ...

  1. #41
    Member bberretta's Avatar
    Join Date
    Aug 2009
    Location
    Memphis, TN
    Posts
    665

    Bright Red
    2000 TA Firehawk 0041/742

    System works pretty simply:

    When you press the pedal, the master cylinder sends fluid to the slave cylinder. As the slave cylinder fills, it pushes the throwout bearing into the pressure plate.

    If your pedal works fine up to 4k, I'm going to guess its not the master cyl but rather something in the clutch that is keeping it from engaging. The reason I say this is no matter the speed, the pedal should move in and out, the fluid should move through the system and the slave cylinder should move the bearing. The only things that change at various RPMs the motor, clutch and transmission.

    I'm sure someone with more knowledge than me can better diagnose it.
    2000 Pontiac Firehawk #0041 of 742

  2. #42
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Well, we got the car up on a lift and the problem was the line connecting the master to the transmission popped off resulting in losing all of my fluid. Should be fixed tomorrow and ill give you guys an update

  3. #43
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I had a feeling something blew.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch Pedal Pressure and Smelly Clutch
    By race5050 in forum Manual Transmission
    Replies: 1
    Last Post: 01-06-2010, 06:37 PM
  2. Clutch Pedal Problem
    By juxi in forum Manual Transmission
    Replies: 1
    Last Post: 01-27-2008, 04:11 PM
  3. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 5
    Last Post: 09-14-2007, 03:41 PM
  4. Fading Clutch Pedal with new clutch
    By mrbob2 in forum Manual Transmission
    Replies: 2
    Last Post: 08-17-2007, 06:58 PM
  5. clutch/pedal problem
    By tubjub in forum Manual Transmission
    Replies: 8
    Last Post: 04-16-2007, 02:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •