Page 1 of 3 123 LastLast
Results 1 to 20 of 43

Clutch pedal problem

This is a discussion on Clutch pedal problem within the General Help forums, part of the LSx Technical Help Section category; I finally got around to getting the new Tick Performance Master cylinder put in. The car is still doing the ...

  1. #1
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Clutch pedal problem

    I finally got around to getting the new Tick Performance Master cylinder put in. The car is still doing the same thing it was before; the pedal is sticking to the floor after going WOT up to 6700 RPMs in every gear that I have tried it in. Also, I can't put the car in gear while the pedal is sticking, when I go to change gears while it's sticking it's like the clutch isnt even engaged even though the pedal is depressed fully. It has improved some since the Master install; I can go to around 6K Rpms without it sticking. Any suggestions as what I should replace next? Could it be the clutch? Or is it more likely the slave/throwout??? Maybe something isnt lined up right down there??? Thanks for any input, this is driving me up the wall.

    It never did this until I installed heads/cam. I'm now making around 420 to the wheels (Dynoed 416 before the UD pulley and New TB) Also, the clutch is an LS7 clutch that is about a year old.

  2. #2
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    I am betting wslave cylinder. I replaced mine wen i did my ls7 clutch swap

  3. #3
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Cool, I have one, just didnt want to have to pull the trans to install it if the master fixed it. I guess I'll go ahead and get a monster clutch while I am at it.

  4. #4
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    Yeah, i did swapped it out cuz my pedal was sticking. When i did my ls7 i did the master and slave and drill mod all together

  5. #5
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    It could be a weak pressure plate. Sounds like you might fix the problem with the monster clutch

  6. #6
    Junior Member BADHAWK209's Avatar
    Join Date
    Jun 2010
    Location
    Stockton,CA
    Posts
    53

    BLACK
    00 TRANS AM M6

    mine is acting up too i grinded 4th gear this morning its very anoyying

  7. #7
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    I'm kinda missing my auto car since all this started lol.

  8. #8
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    i have a monster clutch. Installed it about 4 months ago and have no sticky clutch you speak of.

  9. #9
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    If/when you install the Monster, and the problems cease, the only issue you will have will be...












    TRACTION.





    Keep us posted OP.

  10. #10
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Quote Originally Posted by cammed goat View Post
    If/when you install the Monster, and the problems cease, the only issue you will have will be...












    TRACTION.





    Keep us posted OP.
    I already have issues with Traction since the heads and cam I love driving my car now, it pulls like a freight train up top.

  11. #11
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by wooddaniel View Post
    I already have issues with Traction since the heads and cam I love driving my car now, it pulls like a freight train up top.
    Hehehehehehehehe

  12. #12
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    I need slicks....

  13. #13
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Oh, by the way cammed goat, saw that you're from NJ I'm going to Fort Dix NJ in two weeks when I deploy. Any good places to party that you know of?

  14. #14
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I've never been to Ft Dix so I don't know any nearby hangouts.

  15. #15
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Quote Originally Posted by cammed goat View Post
    I've never been to Ft Dix so I don't know any nearby hangouts.
    Thought I'd ask. 1st time going to Jersey.

  16. #16
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Update: I was driving on I95 today and downshifted to 4th to pass a slow semi. When I passed him, My pedal didnt come back up as usual. It eventually came back up, but it's like it's swinging freely and the clutch will not disengage. I drove the car 250 miles home without a clutch stuck in 4th gear... it just quit on me out of nowhere. throwout bearing break? Im getting it towed to a shop tomorrow.

  17. #17
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I am thinking you're right. Your pedal shouldn't just be flopping back and forth. Any noises from the trans while you were driving after the pedal incident?

  18. #18
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Quote Originally Posted by cammed goat View Post
    I am thinking you're right. Your pedal shouldn't just be flopping back and forth. Any noises from the trans while you were driving after the pedal incident?
    No unusual noises, just the pedal swings freely and I have to slam the gears if I wanna change them. Getting home was an adventure I had to circle in parking lots when there was a red light

  19. #19
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I'm wondering if the slave went? I can't remember if the throwout bearing for the Tremec has needle bearings. If the throwout bearing has needle bearings in it, then there should have been some sort of rattling noise I would imagine.

  20. #20
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Quote Originally Posted by cammed goat View Post
    I'm wondering if the slave went? I can't remember if the throwout bearing for the Tremec has needle bearings. If the throwout bearing has needle bearings in it, then there should have been some sort of rattling noise I would imagine.
    When it happened, I heard a slight pop. No more noises afterwards

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch Pedal Pressure and Smelly Clutch
    By race5050 in forum Manual Transmission
    Replies: 1
    Last Post: 01-06-2010, 06:37 PM
  2. Clutch Pedal Problem
    By juxi in forum Manual Transmission
    Replies: 1
    Last Post: 01-27-2008, 04:11 PM
  3. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 5
    Last Post: 09-14-2007, 03:41 PM
  4. Fading Clutch Pedal with new clutch
    By mrbob2 in forum Manual Transmission
    Replies: 2
    Last Post: 08-17-2007, 06:58 PM
  5. clutch/pedal problem
    By tubjub in forum Manual Transmission
    Replies: 8
    Last Post: 04-16-2007, 02:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •