Results 1 to 7 of 7

Clutch issues.

This is a discussion on Clutch issues. within the General Help forums, part of the LSx Technical Help Section category; to make this short and easy.. about a week or two ago, my clutch was getting soft and to the ...

  1. #1
    Junior Member
    Join Date
    Nov 2013
    Location
    Miami, FL
    Posts
    15

    Pewter
    2000 Trans AM

    Clutch issues.

    to make this short and easy.. about a week or two ago, my clutch was getting soft and to the point that it would not even go into 1st or reverse.. and when it did if i lifted my foot 1 centimeter it would engage and car would start moving. come to find out my clutch reservoir was empty!! I filled it up with dot 3 fluid as specified. a day or two later it was empty again so I filled it up. it is slowly losing oil somewhere. I checked all the spots I have read online behind the pedal, under the brake booster even put cardboard under the car between engine and tranny to see if it was leaking and nothing no leaks whatsoever!! Where the hell is this fluid going?

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    check the connector where the hydraulic hose connects to the slave. Sometimes they are not installed properly and can leak is damage.


    Try filling the reservoir back up and have some one press the clutch pedal while you are under the car. A leak that bad has to show some where.

  3. #3
    Junior Member
    Join Date
    Nov 2013
    Location
    Miami, FL
    Posts
    15

    Pewter
    2000 Trans AM

    found the leak is this the slave?

  4. #4
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Yep. Slave is bad. Speaking from experience.


    extreme dimensions, driveshaft shop, harrop, hid(35watt/6k) lows, hurst, k&n, led fogs, maverick man, mishimoto, nitto, revshift, slp, stern st-1, smoked sidemarkers, whiteline poly radius rod bushings

  5. #5
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    You'll need a new clutch as well as some of the fluid has contaminated the clutch friction material.

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by cammed goat View Post
    Yep. Slave is bad. Speaking from experience.
    Quote Originally Posted by cammed goat View Post
    You'll need a new clutch as well as some of the fluid has contaminated the clutch friction material.

  7. #7
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    No other way around that one. Pull the tranny and clutch.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch issues
    By Tyjack17 in forum Manual Transmission
    Replies: 1
    Last Post: 12-08-2015, 07:19 AM
  2. Clutch Issues
    By V8MUSCLE in forum Drivetrain
    Replies: 9
    Last Post: 12-15-2014, 02:30 PM
  3. clutch hyd issues
    By werewolf in forum Manual Transmission
    Replies: 19
    Last Post: 12-28-2011, 04:18 PM
  4. Clutch Issues
    By BirdCountry02 in forum Manual Transmission
    Replies: 5
    Last Post: 07-30-2009, 06:32 PM
  5. CLUTCH issues..
    By foxman92 in forum Manual Transmission
    Replies: 33
    Last Post: 07-19-2009, 11:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •