Results 1 to 6 of 6

clunk in the floor pan?

This is a discussion on clunk in the floor pan? within the General Help forums, part of the LSx Technical Help Section category; i have an 02 z28 a4, and both when driving and at a stop i can occassionally feel a clunk ...

  1. #1
    Junior Member
    Join Date
    Apr 2007
    Location
    texas
    Posts
    8

    black
    02 camaro z28

    clunk in the floor pan?

    i have an 02 z28 a4, and both when driving and at a stop i can occassionally feel a clunk in my footwell. it is fairly steady when it occurs, but i haven't been able to single it out. my father has driven it and said that when accelerating it feels like a bad u-joint, but the clunk at idle seems more severe than that? anyone got any idea where i should start looking? i have a fwd background, so these rwd parts get me right now =)

    joey

  2. #2
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,328

    BLACK
    Z/28 LS1

    Transmission mount??? or maybe a u-joint??? I have a automatic in my car and it makes a lil noise but seems to be fine.

  3. #3
    Junior Member
    Join Date
    Apr 2007
    Location
    texas
    Posts
    8

    black
    02 camaro z28

    i was kinda leaning toward the tranny mount too... can somebody with experience tell me if this is a hard fix? i love working on cars, but with my work schedule i need to know how long i need to be off to do the work properly. thx in advance.

    joey

  4. #4
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,328

    BLACK
    Z/28 LS1

    Quote Originally Posted by jose2k View Post
    i was kinda leaning toward the tranny mount too... can somebody with experience tell me if this is a hard fix? i love working on cars, but with my work schedule i need to know how long i need to be off to do the work properly. thx in advance.

    joey
    If it is a trans mount about 15 minutes at the most. They cost about 15 bucks for a shitty autozone one a original GM is around $50 I think. Go with the GM if you have the cash flow. GMpartsdirect.com

  5. #5
    Junior Member
    Join Date
    May 2007
    Location
    Dallas
    Posts
    2
    I have the same noise on my 94' Z28, just started today. Sounds like some thing loose or vibrating. I can feel the car loosing power when the noise happens then it goes away and runs fine for a while. It only happens when the car is in drive, it does not make any noise when it is in park. Also the check engine light started coming on. Please Help!!!
    Last edited by wolfer69; 05-04-2007 at 09:27 PM. Reason: added to my question

  6. #6
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,328

    BLACK
    Z/28 LS1

    Quote Originally Posted by wolfer69 View Post
    I have the same noise on my 94' Z28, just started today. Sounds like some thing loose or vibrating. I can feel the car loosing power when the noise happens then it goes away and runs fine for a while. It only happens when the car is in drive, it does not make any noise when it is in park. Also the check engine light started coming on. Please Help!!!
    Go get it put on a diagnostic computer to tell you what codes are being thrown. If you dont know what that means---when your car has a problem the on board computer in your car has a designated code(or number) for each problem your car may encounter (when the check engine light comes on a code is being thrown). They have the codes posted on this website somewhere but your mechanic should know. Some people go to autozone and get them to hook their diagnostic to the car and find out which codes are being thrown on their own, but I dont trust the people working there to be pluging shit into my car. Hope this helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. loud clunk
    By 01outlaw in forum Drivetrain
    Replies: 4
    Last Post: 02-28-2007, 05:48 AM
  2. Help! Clutch won't disengage!I think!
    By '99 SLP#24 in forum Manual Transmission
    Replies: 9
    Last Post: 10-18-2006, 11:14 PM
  3. Clunk Sound Tranny Mounts/
    By chvydav99 in forum Automatic Transmission
    Replies: 0
    Last Post: 08-28-2006, 01:59 AM
  4. 99 TA Rear Clunk
    By pontiac_god in forum Drivetrain
    Replies: 8
    Last Post: 01-25-2006, 03:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •