Results 1 to 6 of 6

Clicking noise after a few WOT pulls

This is a discussion on Clicking noise after a few WOT pulls within the General Help forums, part of the LSx Technical Help Section category; I've just started to notice that after I do a few WOT pulls to 5,500rpm or so, when I finally ...

  1. #1
    Member
    Join Date
    Oct 2005
    Location
    Fort Rucker
    Age
    28
    Posts
    182

    Black
    2001 Trans Am WS6

    Clicking noise after a few WOT pulls

    I've just started to notice that after I do a few WOT pulls to 5,500rpm or so, when I finally let off I get a clicking/swirling sound from the engine bay. The car also seems to not want to rev as much after this. For example, when I press in the clutch and push down the gas pedal, it doesn't rev as high as it normally does with an equal pedal push. After driving normally for about ten minutes or turning the car off and letting it sit, it's back to normal. However, I'm concerned about this noise, as I don't want to damage my precious WS6 in any way. It's a 2001 WS6 Trans Am, M6, pretty much stock besides K&N air filter and a few other litte things. It has 51,000 miles. I'm hoping this noise isn't anything serious or is an easy fix.

  2. #2
    Member keliente's Avatar
    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Age
    31
    Posts
    723
    99 Firebird Formula

    If it's during the end of the run and sounds like a rattling noise, could be spark knock.

    If it's ticking/tapping all the time, you may have bent a pushrod...

  3. #3
    Member
    Join Date
    Oct 2005
    Location
    Fort Rucker
    Age
    28
    Posts
    182

    Black
    2001 Trans Am WS6

    It's at the end of a run, and goes away after five to ten minutes. How do I fix a "spark knock"? I'm running 93 octane.

  4. #4
    Story of My Life!! BIG D's SS's Avatar
    Join Date
    Aug 2005
    Location
    Commerce Ga
    Age
    39
    Posts
    4,995

    Black, Blue
    07 TBSS, 07 GSXR1000

    You could be floating the valves. They are hydraulic. So that might be your problem and it takes a few minutes for them to pump back up. You shouldn't have spark knock with 93.

  5. #5
    Member
    Join Date
    Oct 2005
    Location
    Fort Rucker
    Age
    28
    Posts
    182

    Black
    2001 Trans Am WS6

    It definately sounds like something with the valves. I had a honda prelude before this car, and it died at 184k miles after it began continously making a more violent version of the noise I hear for a few minutes after some hard WOT pulls. What can I do to prevent this "floating" and not damage my engine?

  6. #6
    Member keliente's Avatar
    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Age
    31
    Posts
    723
    99 Firebird Formula

    Quote Originally Posted by BIG D's SS
    You could be floating the valves. They are hydraulic. So that might be your problem and it takes a few minutes for them to pump back up.
    The lifters, you mean.

    Quote Originally Posted by BIG D's SS
    You shouldn't have spark knock with 93.
    A lot of 01-02 cars will spark knock no matter what octane you are running, because of the oil consumption issue via PCV.

    However spark knock is seldom heard at any time except wide open throttle so I don't think it's the case here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •