Results 1 to 6 of 6

Check Gauges Light & Bouncing Needles at High RPMS (Video)

This is a discussion on Check Gauges Light & Bouncing Needles at High RPMS (Video) within the General Help forums, part of the LSx Technical Help Section category; Hey all, My buddy Steve and I rebuilt the top end of my motor a couple weeks ago. No real ...

  1. #1
    Junior Member PAFirefighter11's Avatar
    Join Date
    Apr 2012
    Location
    West Chester, PA
    Posts
    27

    Black/White | Black
    98 TA | 01 WS6

    Cool Check Gauges Light & Bouncing Needles at High RPMS (Video)

    Hey all,

    My buddy Steve and I rebuilt the top end of my motor a couple weeks ago. No real issues at all, and this really isn't an "issue" either. When I get to higher RPM's through the gears I'm seeing the needles bounce and the Check Gauges light on. It's slightly annoying as don't want to get past redline. With bouncing needles it's hard to tell exactly what RPM I'm really at.

    Here is the video:


    I'll grab a better quality video shortly... Any idea's as to cause? I'm thinking BCM, gauge cluster itself, bad ground?

    Thanks...

  2. #2
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    I would look over all your grounds first like you mentioned, is this a problem that started after the rebuild?

  3. #3
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    I agree with tater. Go back and look at all the wires that got removed and check the grounds as well.

  4. #4
    Junior Member PAFirefighter11's Avatar
    Join Date
    Apr 2012
    Location
    West Chester, PA
    Posts
    27

    Black/White | Black
    98 TA | 01 WS6

    Everything looks good, including the grounds on the back of the driver side head.

  5. #5
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Might be a good idea to double check the connections on the PCM. Maybe one of the pins has a bad connection

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I'll third it, really sounds like a ground or connection issues. Any wiring get damaged during the rebuild, or routed to close to the exhaust when things went back together?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. check gauges light
    By ls1wallen in forum General Help
    Replies: 5
    Last Post: 02-25-2011, 06:30 PM
  2. Help: check gauges light
    By GWTWayne in forum General Help
    Replies: 6
    Last Post: 08-11-2009, 06:57 PM
  3. Check Gauges Light
    By wnmech in forum Firebird / WS6
    Replies: 5
    Last Post: 04-02-2007, 11:58 AM
  4. Check Gauges Light?
    By SailorZ28 in forum General Help
    Replies: 5
    Last Post: 04-03-2006, 03:33 PM
  5. check gauges light
    By wooten in forum Computer & Tuning
    Replies: 6
    Last Post: 02-14-2006, 03:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •