Results 1 to 7 of 7

check gauges light

This is a discussion on check gauges light within the General Help forums, part of the LSx Technical Help Section category; Help Please! I have a 98 WS6 with a LS1 engine, i had a check engine light come on which ...

  1. #1
    Junior Member
    Join Date
    Feb 2008
    Location
    North Carolina
    Posts
    6

    Black
    1998

    check gauges light

    Help Please! I have a 98 WS6 with a LS1 engine, i had a check engine light come on which showed 1 bad knock sensor. I pulled the intake and replaced BOTH knock sensors even though I only had 1 bad one. Now I have a "check gauges" light on and the oil pressure & temp gauges are not working. All of the wires have been reconnected. Does anyone have any suggestions or does anyone know what color the wires are going to the sending unit from the gauges. As you all know things are really tight back there

  2. #2
    Senior Member 00z28bubba's Avatar
    Join Date
    Dec 2007
    Location
    las vegas, nv
    Age
    29
    Posts
    1,390

    white
    2000 Z28

    Quote Originally Posted by GWTWayne View Post
    Help Please! I have a 98 WS6 with a LS1 engine, i had a check engine light come on which showed 1 bad knock sensor. I pulled the intake and replaced BOTH knock sensors even though I only had 1 bad one. Now I have a "check gauges" light on and the oil pressure & temp gauges are not working. All of the wires have been reconnected. Does anyone have any suggestions or does anyone know what color the wires are going to the sending unit from the gauges. As you all know things are really tight back there
    if you had to pull the intake manifold then more than likely you busted the oil sending unit behind the manifold. all the vacuum lines and wiring harness were literally wrapped around my OSU to the point where i couldnt avoid breaking it. when i replaced it my oil pressure was off because i didnt tighten it all the way. when i tightened everything was reading fine again.

  3. #3
    Member Rk ws6's Avatar
    Join Date
    Apr 2009
    Location
    Hagerstown, Maryland, United S
    Age
    27
    Posts
    555

    Red
    2001 ws6

    x2!

  4. #4
    Junior Member
    Join Date
    Feb 2008
    Location
    North Carolina
    Posts
    6

    Black
    1998

    so it looks like I am going to have to pull the intake off again and check to see if i broke the sending unit? Any hints as to what I am looking for, i did not recall seeing a typical sensor back there.

  5. #5
    Senior Member 00z28bubba's Avatar
    Join Date
    Dec 2007
    Location
    las vegas, nv
    Age
    29
    Posts
    1,390

    white
    2000 Z28

    mine was on the drivers side of the engine literally right behind the engine. it is about 3" or so tall without being plugged in. mine was pretty brittle to the point that when i tried back out the remainder of the OSU it literally just crumbled in my fingers.i didnt find any images of it right off the bat so i used this pic to give you a general idea of where it sits.


    the sensor looks similar to this.

  6. #6
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    If I can change mine on a 97 with ASR motor monted over there on the right side you can change yours with out pulling the intake. They make a special socket and I managed to get the socket an extention and wrench in there just beside the brake booster. Use teflon on the new one.

  7. #7
    Junior Member
    Join Date
    Feb 2008
    Location
    North Carolina
    Posts
    6

    Black
    1998

    Smile Oil Sending Unit 98 LS-1

    To the guys that helped me THANK YOU! I found the sensor exactly where you said it would be and i had snapped it off. Mine was very brittle as well. Ordered a new one today and will have it up and running again tomorrow...THANKS AGAIN!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. check gauges light
    By ls1wallen in forum General Help
    Replies: 5
    Last Post: 02-25-2011, 06:30 PM
  2. Check Gauges Light
    By wnmech in forum Firebird / WS6
    Replies: 5
    Last Post: 04-02-2007, 11:58 AM
  3. check gauges light?
    By FastAssZ in forum General Help
    Replies: 3
    Last Post: 04-09-2006, 05:42 PM
  4. Check Gauges Light?
    By SailorZ28 in forum General Help
    Replies: 5
    Last Post: 04-03-2006, 03:33 PM
  5. check gauges light
    By wooten in forum Computer & Tuning
    Replies: 6
    Last Post: 02-14-2006, 03:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •