Results 1 to 4 of 4

Check engine light after racing

This is a discussion on Check engine light after racing within the General Help forums, part of the LSx Technical Help Section category; Hey guys, I did a bunch of searching through here before but tonight after a couple of runs on the ...

  1. #1
    Junior Member KylerCavers's Avatar
    Join Date
    Jul 2007
    Location
    Brandon
    Posts
    2

    Navy Metallic Blue
    1999 Camaro SS

    Check engine light after racing

    Hey guys, I did a bunch of searching through here before but tonight after a couple of runs on the highway my check engine light came on. The car is a 99' SS with 90,000 km's, I've had it for about a month and it's in perfect condition with no problems. The car seemed just fine after, all guages were normal and it was running same as always. I live in Manitoba, Canada and don't have an autozone so hopefully some local places can scan the code. Any ideas though of what i could be? I just had a magnaflow put on a couple weeks ago so thats all thats been done to the car.

    Thanks

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    could be a bunch of things. Try to get the code read. That'll answer all your questions. Not sure in Canada but pretty much all auto parts stores here will scan for free. If finding a place to read codes for you is a hassle you may want to look at buying a code reader. You can get some pretty cheap ones on the web although I prefer this one.
    actron cp-9180

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Try having someone read the code and post it. Otherwise i would say disconnect the batter for a bit then reconnect it and see if the light comes back on. It might have just had a moment
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Junior Member KylerCavers's Avatar
    Join Date
    Jul 2007
    Location
    Brandon
    Posts
    2

    Navy Metallic Blue
    1999 Camaro SS

    Well I took her into fountain tire and they scanned it for me. The guy said the code was 137-B, 02 sensor behind the left cat. The light actually went off not long after leaving work on my way to get it checked out and I drove home after, no light and running fine. They quoted me on a replacement sensor/labor and it came to about $200.00. I'm not going to get it done because I'm still going to be doing a full exhaust soon and whether I do ORY or high flows I don't know yet, after all couldn't it just be acting up and not even need replacing?

    p.s sunsetorangess, how do you like your exhaust as well as your other mods over stock? I have the magnaflow and was actually looking to get some ceramic pacesetter LT's. As a matter of fact most of things in you sig besides the spray were nearly dead on what I want to do lol.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Check Engine Light
    By newcomer in forum General Help
    Replies: 9
    Last Post: 07-08-2007, 01:34 AM
  2. How Can I Find Codes For Check Engine!!!
    By camaro_guy in forum Camaro / SS
    Replies: 5
    Last Post: 10-30-2006, 12:53 PM
  3. check engine light
    By ss540 in forum General Help
    Replies: 4
    Last Post: 10-29-2006, 08:01 PM
  4. Replies: 14
    Last Post: 03-30-2006, 12:59 PM
  5. Hate check engine light
    By white-Z in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-22-2005, 03:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •