Results 1 to 4 of 4

car wont engine break

This is a discussion on car wont engine break within the General Help forums, part of the LSx Technical Help Section category; got a problem guys the whole point in have a 6 speed is cuz its fun to shift and downshift ...

  1. #1
    Junior Member
    Join Date
    Jan 2007
    Location
    Cville,GA
    Posts
    25

    Silver and Black
    2002 Z-28 Camaro

    Angry car wont engine break

    got a problem guys the whole point in have a 6 speed is cuz its fun to shift and downshift cuz it sounds good.....IT DONT WORK ON MY CAR!?!?!?! its not reving right it revs slow u can rev it up and the rpms climb and fall slow and i can drop from 4th to 3rd say and the rpms go from like 2000 up to 3000 which is normal but the car should start slowing down and the rpms start to fall and it dont anyways blaaaaaah any suggestions on waht could be causing this it is annoying me thanx

  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Ho w fast do you think its goona slow down? Is this a new problem? Did you just buy this car? So when you downshift from 4th to 3rd, the car stays at the same speed. What happens when you accelerate? I don't get it. This may sound stupid, but my SS floor mat would get jammed under the throttle causing similar problems.

  3. #3
    Junior Member
    Join Date
    Jan 2007
    Location
    Cville,GA
    Posts
    25

    Silver and Black
    2002 Z-28 Camaro

    acceleration is good it pulls hard. ive had the car for lil over a year now and ive got a hurst short throw,LCA's,air intake,flowmaster cat back,let me try to clarify....say im running 2000rpms and in 4th i can drop it into 3rd and say it goes up to 2500-2700rpms. instead of the car even remotely slowing down its like its rolling in neutral and the car will hold stead at those rpms

  4. #4
    Member SSpdDmon's Avatar
    Join Date
    May 2006
    Location
    Farmington, MI
    Age
    36
    Posts
    332

    SOM
    '01 Camaro SS

    Well first off, the engine breaking you're missing is called DFCO (Decel Fuel Cut Off). For it to kick in, there are several conditions in the PCM that have to be satisfied:

    1) Coolant temp needs to be above 122*F
    2) RPM's must be greater than 1900
    3) Vehicle speed must be greater than 28mph
    4) MAP must read below 18.11kPa (high manifold vacuum)
    5) Throttle position % must be below the specified value for the current RPM (varies)
    6) The above conditions must be met for at least 5 seconds

    Once all of that happens, DFCO will kick in. If you're not seeing DFCO kick in, I'd get access to a scanner to see why. The mods you listed shouldn't keep you from entering DFCO. So, it might be MAP or TP% related. Make sure you don't have any vacuum leaks in the intake tract and that your TP% isn't reading high.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •