Page 2 of 2 FirstFirst 12
Results 21 to 26 of 26

Car runs weird after LT install...

This is a discussion on Car runs weird after LT install... within the General Help forums, part of the LSx Technical Help Section category; Honestly, I too feel that changing your spark plug wires is the best Place to start. When your changing them ...

  1. #21
    Member Rob00Taws6's Avatar
    Join Date
    Jun 2007
    Location
    Southern Maryland
    Posts
    255

    black
    2000 pontiac trans am

    Honestly, I too feel that changing your spark plug wires is the best Place to start. When your changing them out for your MSD wires check to see if there are any vacuum leaks, and definitely change out your fuel filter. If none of that makes any difference, check your fuel pressure, see if you have enough pressure. Don’t be afraid to back track ether, have you changed any sensors before you had the headers installed. And, another thing have you tried to disconnect the battery over night and reset the computer. Just for the hell of it, look at your Throttle position sensor, dont take it off just check to see if its been moved from its original position or if its loose.

  2. #22
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    30
    Posts
    1,316

    Black
    1999 Trans Am M6

    Quote Originally Posted by Rob00Taws6 View Post
    Honestly, I too feel that changing your spark plug wires is the best Place to start. When your changing them out for your MSD wires check to see if there are any vacuum leaks, and definitely change out your fuel filter. If none of that makes any difference, check your fuel pressure, see if you have enough pressure. Donít be afraid to back track ether, have you changed any sensors before you had the headers installed. And, another thing have you tried to disconnect the battery over night and reset the computer. Just for the hell of it, look at your Throttle position sensor, dont take it off just check to see if its been moved from its original position or if its loose.
    Thanks for the advice, I'll look into that stuff when I get home this weekend. I also have the msd wires and a new fuel filter waiting for me. The car was actually running pretty good last time I drove it, it didn't hesitate and went thru the rpm's rather smoothly. I'm sure the computer in the car is adapting to the increase in airflow. I still want to have more tuning done tho because the "seat of the pants" difference still isn't much better. She does sound like a beast tho
    1999 Trans Am M6
    SLP Short Throw, Lid and CAI, BMR STB and SFC, UMI PHB, Pacesetter LT's and ORY, Magnaflow Catback, DMH 3" E-Cutout, LS7 Clutch, Motive 4.10, 160 T-Stat, MSD, !AIR, !EGR, 17x9.5 Chrome C6's wrapped in Hankook 275/40/17

    Tuned at Mongillo Motors in New Haven, CT

  3. #23
    Member Rob00Taws6's Avatar
    Join Date
    Jun 2007
    Location
    Southern Maryland
    Posts
    255

    black
    2000 pontiac trans am

    That’s good to hear, honestly I feel some of your pain, 5 years back I built an L98 Lingenfelter engine for my 89 GTA, I had a lot of problems with the OBD I computer that was in the car and trying to convince it to run right. But, like anything you try things some work some don’t and you learn. I like these LS1 engines, I’ve been learning different things about them every day.

  4. #24
    Junior Member
    Join Date
    Sep 2008
    Location
    las Vegas
    Posts
    4
    Hello just joined.Not sure where to post this but I have a L98 C 4 Corvette.I found the compression has decreased by 50% in most cylinders.I have a chance to get a Lt1. Will the LT1 fit in it's place?

  5. #25
    I flame retards CamaroFan71's Avatar
    Join Date
    Aug 2006
    Location
    Baton Rouge, La.
    Posts
    1,068

    QuickSilverMetallic
    2005 GTO M6

    Quote Originally Posted by 0rion View Post
    I would pay the extra and get msd wires. Right now I think you're learning lessons that'll last you a lifetime and we all have to learn these lessons. If you have the manifolds off putting on headers it's always a good idea to replace plugs and wires. How many miles are on your fuel filter? That's an easy replacement that you can do in the driveway in just a few minutes. It may feel like the car is kicking your butt at the moment but it'll get taken care of and after everything is said and done you'll be glad you did the header swap.
    I'll explain why you should get msd wires. I swapped some on my truck several years ago and still had a miss I had been chasing down. I used cheap wires but when I put the wires on to me that pretty much ruled out the wires. I fought that thing for several more days trying to find the miss. One evening just after dark I had the hood up still working on it and something caught my eye. One of my brand new wires had a little tiny "hair" sticking out of the boot that was arcing to the block. I also put some wires on for someone and they bought the cheap wires. Everytime it rained their car would run like crap. I found it was the coil wire, the boot was a little loose on the coil and it was letting moisture in. Just a couple of reasons I would spend the extra $7 for MSD wires.
    Agreed.

  6. #26
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    48
    Posts
    416

    navy blue metallic
    2001 trans am

    My car was doing this as well. Did you remove the AIR and EGR? I got rid of those (no egr 4 me) and that vaccume manifold under the cowl and that did it. Could not give you one reason why it did it or what the problem actually was.
    Last edited by sic2001; 09-12-2008 at 11:16 AM.
    GMPP LS6 crate motor,racetronix,Wilwood 6 piston,HID's,200mph speedo,full dynomat, GY F1's,17" Y2K, Alpine audio upgrade,3" ele cutout, LT's, catted-Y, full suspension

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. She runs!!!!!!!
    By WICKEDLS1 in forum Internal Engine
    Replies: 25
    Last Post: 03-31-2011, 09:43 AM
  2. Z06 with only DR runs 10.85
    By powermad in forum Corvette
    Replies: 20
    Last Post: 11-16-2006, 07:21 PM
  3. It runs once more
    By bigman1 in forum Southern Members
    Replies: 5
    Last Post: 09-24-2006, 12:50 PM
  4. Engine runs rough, idles rough, runs rich
    By skintox in forum General Help
    Replies: 2
    Last Post: 08-22-2006, 04:31 PM
  5. My First runs on the 1/8th
    By evlls1pimp in forum Drag Racing
    Replies: 3
    Last Post: 04-26-2006, 01:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •