Results 1 to 6 of 6

Car just started overheating...

This is a discussion on Car just started overheating... within the General Help forums, part of the LSx Technical Help Section category; Car's never done this but in the past two days if i am stopped at a light the car temp ...

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    31
    Posts
    72

    Black
    1999 Camaro SS

    Car just started overheating...

    Car's never done this but in the past two days if i am stopped at a light the car temp rises drastically, like almost pinning the needle, then when i start moving or turn the heat on it goes back to normal. checked all coolant and oil fluids, everything's good. what could it be??

    1999 Camaro SS

  2. #2
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Blocked Radiator (plastic bag, bugs etc. stuck on it)
    High Temp Fan not coming on
    Sticking Thermostat
    Bad Radiator Cap
    Air in System
    Low or No Coolant in Recovery Tank
    Bad Hose (inside has pocket that collapses blocking flow)

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Like above posted it could be any of those issues.
    The most common are Bad radiator cap, Low coolant, and stickin thermostat.
    Are your fans coming on? Make sure they are coming on around 200ish deg. Should be able too hear them or pop the hood and watch for them too kick on. You can take your cap to a local parts store and they should be able too check it. If all fails then replace your thermostat.
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    31
    Posts
    72

    Black
    1999 Camaro SS

    fans are coming on and there is plenty of water in the overflow/recovery tank and the cap seems to be fine?

  5. #5
    Senior Member Hurley711's Avatar
    Join Date
    Jul 2005
    Location
    Earth
    Age
    40
    Posts
    3,359

    414 RWHP 395 RWTQ
    00 Black Ram Air Trans Am

    Prol thermo as stated above, that was my problem.

  6. #6
    Senior Member 02z28ls1's Avatar
    Join Date
    Sep 2005
    Location
    near St. Louis
    Posts
    1,205

    navy blue
    2002 Z-28 Camaro M6

    Sounds like the fans aren't working.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •