Results 1 to 3 of 3

car back firing bad after I let off throttle

This is a discussion on car back firing bad after I let off throttle within the General Help forums, part of the LSx Technical Help Section category; I have a 2000 camaro ss with a ls1 recently IhIhave had problems with the car backfiring (sounds like a ...

  1. #1
    Junior Member
    Join Date
    Jun 2014
    Location
    council bluffs
    Posts
    1

    car back firing bad after I let off throttle

    I have a 2000 camaro ss with a ls1 recently IhIhave had problems with the car backfiring (sounds like a shot gun) I read the codes and they are saying I have problems with the lower and upper bank and my o2 censors....awhile back someone cut off my kats and I replaced them with hollowed out ones and they also cut my o2 censor wires..now when I get too about 2800 rmp the car starts cutting out like its getting too much or not enough fuel I have no clue whats going on please help

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    so you have no O2's hooked up? The front O2's control fueling so you have to have them. Sounds like your answer to me.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    ^^ Agree. The front O2 senders are absolutely required as they control fueling. By "front" we are referring to the O2 senders located between the heads and the catalytic converter on each side of the car. The rear O2 senders can be removed and plugged off or disconnected and will have no affect on how your engine runs. Their job is to simply tell the PCM if the catalytic converters are working. This being said, disconnecting or removing the rear O2 senders will trigger the SES to light unless you adjust your tune.

    Also, STOP driving the car until you remedy this issue as you risk damaging your engine!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help not firing on all cylinders
    By z28cobrakilla in forum Internal Engine
    Replies: 36
    Last Post: 09-05-2012, 09:50 PM
  2. Header install problem. (back firing)
    By Devildog1371 in forum External Engine
    Replies: 22
    Last Post: 02-12-2010, 04:21 PM
  3. Bump Firing your AR
    By Huskerz1 in forum Gun's & Ammo
    Replies: 8
    Last Post: 01-18-2010, 01:49 PM
  4. firing order
    By juxi in forum Almost Anything Goes
    Replies: 2
    Last Post: 02-26-2008, 04:59 PM
  5. firing order help please...
    By DrMilhouse in forum Internal Engine
    Replies: 2
    Last Post: 04-17-2006, 11:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •