Results 1 to 6 of 6

can't figure out where

This is a discussion on can't figure out where within the General Help forums, part of the LSx Technical Help Section category; Ok guys need your help on this one, got a oil leak can't figure out where it's coming from. It's ...

  1. #1
    Member slpcamaro's Avatar
    Join Date
    Mar 2008
    Location
    sunnyvale
    Posts
    453

    silver
    98 ss camaro

    can't figure out where

    Ok guys need your help on this one, got a oil leak can't figure out where it's coming from. It's coming from the back of the motor somewhere. I had put an ls6 intake manifold on and I had come a little loose so I tried to tighten it, went a little too tight and snapped a bolt. I have the new ones when I took the manifold off I noticed a little oil on the bottom of the intake manifold. And I noticed a metal plate that lays flat under the manifold started to take that off but was late and I couldn't figure out how to unclip the two what look like sense that are in the plate well more like under. So how do I unclipp those, what's this plate and does its have a gasket. Also I had to replace the oil pressure sensor and not sure how to tighten it all the way, not really enough room to get a wrench back there. I figure if I know all these are good and leak still persist then I'm most likely lookin at a leak in the head gasket. It seems to wait till I turn the car off to leak, car runs fine if I get on it the oil pressure drops a little, like I said though the oil pressure sensor was only hand tightened but ran good for a few months since put it on. Thank you for any help on this.

  2. #2
    Slower Than a 3rd Gen juiced99ws6's Avatar
    Join Date
    Aug 2005
    Location
    Cape Coral, FL
    Age
    33
    Posts
    3,097

    Mystic Teal
    99 Trans Am & 01 CBR 929

    If you had a leaking head gasket you would have more issues that just a little oil up under your intake manifold. Chances are that the oil was coming from your oil pressure sending unit. Mine was replaced when I had the motor out for my swap so I do not know how to go about tightening it down on the car but it is something you definatly will have to do.

    The sensors you are referring to are your knock sensors. If I remember right there is a black rubber thing around each wire and they have to get pulled up to expose the nut or bolt that mounts the knock sensors in. I do not recall off the top of my head and I dnt have any pictures from when my knock sensors were still in to refer to. Either way if you take that plate off you will be looking down into where your camshaft is in your block. I would not bother pulling any of it off if it has never been off.

  3. #3
    Slower Than a 3rd Gen juiced99ws6's Avatar
    Join Date
    Aug 2005
    Location
    Cape Coral, FL
    Age
    33
    Posts
    3,097

    Mystic Teal
    99 Trans Am & 01 CBR 929

    Sorry I couldn't be more specific on the details but I also noticed something else. Hopefully it is all just related to your oil pressure sending unit but you said when you get on it your oil pressure drops.. it shouldn't drop, it should rise. So I would definatly say that your problem lies within that sensor.

  4. #4
    Slower Than a 3rd Gen juiced99ws6's Avatar
    Join Date
    Aug 2005
    Location
    Cape Coral, FL
    Age
    33
    Posts
    3,097

    Mystic Teal
    99 Trans Am & 01 CBR 929







    Here is case you are curious as to what is under that cover still... sorry no pics with the knock sensors still in so it didnt really jog my memory any.

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    sounds like your oil is coming from the pressure sensor. Take the intake off to tighten that down so there's more room to work. It gets broken a lot of times by the large vacuum line that runs over to the brake booster so be careful when putting the intake back on that you work that line around the sensor and don't break the sensor again.

  6. #6
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Go to your local car parts store and they sell opsu sockets taht will fit over the whole sensor, as far as those clips your talking about just brake the top of them off. Don'y forget to grind the fins down before you put that manifold on if you haven't already. You probably need to call up newtech or synergy.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trying to figure out what I need? Need help please
    By rcorte3001 in forum General Help
    Replies: 4
    Last Post: 08-16-2010, 06:26 PM
  2. Cant seem to figure this one out
    By JML6820 in forum General Help
    Replies: 2
    Last Post: 08-16-2010, 07:52 AM
  3. Help me figure out what this is!
    By mariner3302 in forum General Help
    Replies: 10
    Last Post: 08-24-2007, 04:48 PM
  4. Err I cant figure this out
    By CurrentlyPissed in forum Firebird / WS6
    Replies: 3
    Last Post: 06-30-2007, 07:57 PM
  5. Can anyone figure this out, i cant
    By ss~zoso~ss in forum Almost Anything Goes
    Replies: 115
    Last Post: 03-04-2007, 08:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •