Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Camaro won't start!

This is a discussion on Camaro won't start! within the General Help forums, part of the LSx Technical Help Section category; Help, my car wouldn't start today! I turned the key, all the lights came on as normal but when I ...

  1. #1

    Unhappy Camaro won't start!

    Help, my car wouldn't start today! I turned the key, all the lights came on as normal but when I turned the key to start it, there was a clicking sound as though a cog was trying to spin against something that was stuck.

    It's only been one week since last use and I keep it in a garage when I'm not using it.

    Now here's the big problem, the average garage in the UK is small so I need to get it out of the garage to work on it, but as it's an auto I can't get it out of Park and into Neutral without first starting it, but I need to get it into Neutral so I can roll it out of the garage or at least far enough out so I can get easy access under the hood.


    A really tricky situation here, I'd really appreciate if anyone can help.

    Thanks in advance.

  2. #2
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    clicking sound = dead battery


  3. #3
    Junior Member whitetrashbird's Avatar
    Join Date
    Dec 2010
    Location
    Tx
    Posts
    65

    Blue
    02 Firebird Transam

    Sounds like the battery is dead (or bad connection). If you have enough power for the lights to come on, you should have enough to trip the shift lock off. As long as the key is in the "run" position, you should be able to shift it out of park even if it's not running.

    Dan

    "Timid men prefer the calm of despotism to the tempestuous sea of liberty"....Thomas Jefferson

  4. #4
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    When you replace the battery, make sure to start the car for a few minutes when the car isn't in use. This will keep the battery from dying prematurely from lack of use.

  5. #5
    That is exactly the sound, I'm going to borrow my Dad's battery charger and check connections.

    Thank you so much.


  6. #6
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    my pleasure man.

  7. #7
    I charged the battery for 24 hours and now the car starts normally Does the battery's loss of power indicate a replacement is needed? Are there any issues with the standard AC Delco, if so, does anybody have alternative recommendations?

    Cheers all.

  8. #8
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    how old is it? 4 years is a typical battery life span. I've always used optima red tops, never had an issue.

  9. #9
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Same here I had my optima for 3 yrs now and not a single issue.

  10. #10
    Quote Originally Posted by justinmc978 View Post
    how old is it? 4 years is a typical battery life span. I've always used optima red tops, never had an issue.

    Quote Originally Posted by JayTA98 View Post
    Same here I had my optima for 3 yrs now and not a single issue.
    I don't know the battery's age, but the previous owner of the car had it for three and half years and he told me he'd not changed the battery in that time. I bought it in August, so maybe it is due for a new one. I'll see if optima are available here in the

  11. #11
    Drop&Drag matt evans's Avatar
    Join Date
    Jan 2010
    Location
    clyde nc
    Posts
    287

    black
    02 Z28 and 00 SS

    optima=

  12. #12
    Optima batteries are availabe in the UK.

    Is the one in this link: Red Top 4.2 U - Optima Batteries UK the one that you have in your cars?

  13. #13
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    OP, a couple of other things to check.


    Battery - you've charged it good. Age might be the problem but the alternator and ground could also lead to battery failure.

    Alternator - Check it, age and a leaky power steering pump can cause the alternator to die out. If your PS pump is leaking there are a couple of stickies that can help on fixing that. If no leaks, still get it checked out. A weak or dead alternator will kill the battery, replace if needed.

    Ground - follow the black cable to where it meets the body, should be right next to the battery on the passenger fender. If it is corroded or loose - clean and re-tighten.

  14. #14
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by SS Camaro UK:2723448
    Optima batteries are availabe in the UK.

    Is the one in this link: Red Top 4.2 U - Optima Batteries UK the one that you have in your cars?
    Don't waste your money on optima. The price is too high for no benefit over a acdelco, diehard, interstate, etc.

    Use the money saved to buy a battery tender and it will make it outlast a optima.
    "Some people live for the rules..... I live for exceptions" N. Hexum

  15. #15
    I'm having a real problem with getting a battery, they are available but nobody will ship it's collection only, can you believe it?

    I did however find this Top Post to Side Terminal Conversion Cable Pair #5505-010 and wondered if I could buy a top terminal battery, there's plenty locally available and use these.

    Any thoughts?

  16. #16
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Try that idea. Improvisation is key if you cannot get a side terminal battery.

  17. #17
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by KMdef9 View Post
    Don't waste your money on optima. The price is too high for no benefit over a acdelco, diehard, interstate, etc.

    Use the money saved to buy a battery tender and it will make it outlast a optima.
    I always used diehard and interstate. They are awesome batteries. I will most likely get me one of those when my optima needs replacement.

  18. #18
    Great news, I finally found a place that ships and funnily enough they're only 15 miles away so I could easily collect as well.

    Isn't it strange, that you can't see what's right in front of you?

  19. #19
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I know that feeling.

  20. #20
    Just a quick update with a question. I borrowed my Dad's battery charger and left it low charging my Camaro for just over a week and noticed that the magic eye indicator is now showing green for good. Does this mean that the battery doesn't need replacing after all?
    If this is the case, I could get a battery tender of my own straight away to keep the battery maintained.

    Thanks all.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lets start a Camaro Club....
    By Cagefighter in forum Mid-West Members
    Replies: 17
    Last Post: 10-17-2011, 08:43 AM
  2. 02sunsetorangeZ's 1967 Camaro start up.
    By ldurham in forum Member's Rides
    Replies: 5
    Last Post: 07-28-2011, 07:09 PM
  3. Help: HELP camaro wont start :(
    By SSickLS1 in forum Camaro / SS
    Replies: 3
    Last Post: 03-19-2011, 12:29 PM
  4. 1997 Camaro V6 won' start
    By oldguy in forum General Help
    Replies: 4
    Last Post: 05-19-2007, 04:59 PM
  5. another ls1 camaro cranks no start question
    By ssscamaro in forum General Help
    Replies: 17
    Last Post: 10-16-2006, 10:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •