Results 1 to 5 of 5
Like Tree3Likes
  • 1 Post By 0rion
  • 1 Post By pajeff02
  • 1 Post By 2002ssslp

a/c moldy stale smell. How unclog evap drain hose

This is a discussion on a/c moldy stale smell. How unclog evap drain hose within the General Help forums, part of the LSx Technical Help Section category; Next newbie question: i've got that moldy smell a day after a/c runs, and folks say a simple clogged evaporator ...

  1. #1
    Member BobbyGFirebird's Avatar
    Join Date
    Jul 2015
    Location
    NY
    Posts
    125
    Blog Entries
    1

    a/c moldy stale smell. How unclog evap drain hose

    Next newbie question: i've got that moldy smell a day after a/c runs, and folks say a simple clogged evaporator drain hose. But, what is BEST way to clean or unclog it with simple tools? Video, pics. Thanks.

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    run a coat hanger up that hose....is your passenger carpet getting wet? If not it may not be a clogged hose but just moisture in the vents. My truck is bad about doing that. When it's real humid for a while it'll have a musty smell when you first turn on the a/c. I just make it a point a couple times a summer to spray some lysol into the outside air induction vent with the fan on high. Problem solved.
    Quote Originally Posted by Mean Green Z28 View Post
    Don't worry about understanding women. Women understand women, and they hate each other

  3. #3
    Member BobbyGFirebird's Avatar
    Join Date
    Jul 2015
    Location
    NY
    Posts
    125
    Blog Entries
    1
    Thanks. Do you know where the evap drain hose on '99 Firebird is found under the hood? I don't think my carpet wet. Smell is just from the vents. A/c had not been workimg for over a year per prior owner, and i just got it going with the Refrigerant charge/bottle. On my darn Japanese wagon, you can't miss it cause it leaks like a broken fire hydrant on every parking spot ! :-)

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Drain hose is accessed from under the car, back by the firewall, maybe passenger side if I remember correctly.

  5. #5
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Don't forget the Lysol, you may have some mold in the box.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Evap purge solenoid!
    By MasonWS6 in forum External Engine
    Replies: 1
    Last Post: 11-11-2015, 08:32 AM
  2. Moldy Smell In My F-Body
    By CamaroCrazyChris in forum General Help
    Replies: 13
    Last Post: 08-20-2015, 01:01 PM
  3. EVAP Code
    By SMWS6TA in forum General Help
    Replies: 11
    Last Post: 05-02-2012, 09:21 AM
  4. Evap Code
    By bigrondownhiller in forum General Help
    Replies: 18
    Last Post: 05-03-2011, 04:33 PM
  5. evap solenoid
    By 06goat60 in forum GTO
    Replies: 16
    Last Post: 06-13-2009, 10:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •