Page 2 of 2 FirstFirst 12
Results 21 to 22 of 22

A/C issues

This is a discussion on A/C issues within the General Help forums, part of the LSx Technical Help Section category; Originally Posted by twozs don't clutches work on adhesion? and isn't WD 40 a LUBRICANT ? in my 20 plus ...

  1. #21
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by twozs View Post
    don't clutches work on adhesion? and isn't WD 40 a LUBRICANT ? in my 20 plus years of ac experience probably not a good idea.. would you think of spraying a manual trans clutch disk with WD 40? you guys should leave the ac stuff to the experts instead of adding "lube" or unmeasured refrigerant oil into the system . too much and you'll fill the evap coil and that it!
    Technically its a water displacement not a lubricant
    Quote Originally Posted by Cutlass View Post
    Internal compressor noise. When it completely goes, you'll most likely have to flush the metal shavings out of the system.
    So changing it now would stop me from having to get it flushed later or damned if I do/don't sort of deal.

  2. #22
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by c5z28 View Post
    So changing it now would stop me from having to get it flushed later or damned if I do/don't sort of deal.
    Probably. You should check the screen in the orfice tube for metal. If you don't see any then no flush is required.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. tv issues
    By 2000redcamaro in forum Almost Anything Goes
    Replies: 15
    Last Post: 12-24-2009, 10:47 AM
  2. Q-Jet Issues?
    By pajeff02 in forum Classic Muscle
    Replies: 7
    Last Post: 09-07-2009, 01:31 PM
  3. will 20's fit on gto with no issues
    By johnjr45 in forum GTO
    Replies: 4
    Last Post: 08-11-2007, 05:48 PM
  4. PM Issues
    By schtick in forum Request and Feedback
    Replies: 0
    Last Post: 07-10-2007, 06:54 PM
  5. Having some serious issues.
    By Banshee1967 in forum Suspension and Handling
    Replies: 2
    Last Post: 03-31-2007, 08:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •