Results 1 to 5 of 5

broken water temp sending unit

This is a discussion on broken water temp sending unit within the General Help forums, part of the LSx Technical Help Section category; so i put a set of long tubes on my 2000 z28 and some how managed to knock the head ...

  1. #1
    Junior Member killa-z's Avatar
    Join Date
    Sep 2009
    Location
    vancouver
    Posts
    2

    gold
    2000 Z/28

    broken water temp sending unit

    so i put a set of long tubes on my 2000 z28 and some how managed to knock the head of the water temp sending unit any body know the easiest way to get it out other then an easy out tool or something or if that will make it worse please help!!!

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    So you are saying you broke the hex part of it and the threaded portion is still in the head? Is there anything that you could put vise-grips on?

  3. #3
    Junior Member
    Join Date
    Aug 2005
    Location
    Kentucky
    Age
    65
    Posts
    91

    S O M
    2002 Camaro SS

    I'd try an easy out first. Worst case scenario, you drill it & put a helicoil in.

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    You broke that whole thing off?? I've seen people break the plastic part off but not the whole nut. Easy out would probably be your best bet.

  5. #5
    Junior Member killa-z's Avatar
    Join Date
    Sep 2009
    Location
    vancouver
    Posts
    2

    gold
    2000 Z/28

    Broken water temp fixed!!!!!

    Used an easy out thanks for the support !!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Sending unit seal
    By kingls1 in forum General Help
    Replies: 9
    Last Post: 05-18-2011, 06:24 AM
  2. Help: oil sending unit
    By ls1ws6ben in forum General Help
    Replies: 10
    Last Post: 01-31-2011, 07:41 AM
  3. Question: Oil sending unit
    By lancesT/A in forum General Help
    Replies: 7
    Last Post: 12-09-2009, 12:37 PM
  4. Help: Oil Sending Unit
    By GWTWayne in forum General Help
    Replies: 2
    Last Post: 08-10-2009, 04:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •