Results 1 to 10 of 10

Broken gas guage

This is a discussion on Broken gas guage within the General Help forums, part of the LSx Technical Help Section category; Started up my 2000 SS today and noticed gas guage read Empty. Tank is full bc i filled it up ...

  1. #1
    Junior Member
    Join Date
    Nov 2007
    Location
    Green Bay, WI
    Age
    32
    Posts
    55

    Black
    2000 SS Camaro M6

    Broken gas guage

    Started up my 2000 SS today and noticed gas guage read Empty. Tank is full bc i filled it up before storage. Everything else seemed fine. Is this an easy fix or is it going to be a bitch?

  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Quote Originally Posted by peteSS View Post
    Started up my 2000 SS today and noticed gas guage read Empty. Tank is full bc i filled it up before storage. Everything else seemed fine. Is this an easy fix or is it going to be a bitch?
    Drive it around some and see if that helps. Chances are it is just stuck.

  3. #3
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    that sucks caseu if it is broken could be a couple 100 dollars for a cluster, cause i never heard of repairing a cluster

  4. #4
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Quote Originally Posted by greatwhiteZ28 View Post
    that sucks caseu if it is broken could be a couple 100 dollars for a cluster, cause i never heard of repairing a cluster
    I doubt it is the cluster.

  5. #5
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    could be sections of clusters, has gone bad lots of times, but another long shot could be elcectrical to the float but i have no exp. with that

  6. #6
    Cookie Monster LukesSpeedShop's Avatar
    Join Date
    Apr 2007
    Location
    Watertown, New York
    Age
    31
    Posts
    126

    Navy Blue Metallic
    2002 Z28

    Yeah, I'd run it for awhile, fill it up a few times see what happens. If its still not working I'd put money on it that you need a fuel level sender. GMs are notorious for them going bad. Gonna have to drop the tank and take out the fuel pump, since its connected to it. Not sure if you can buy just the sedning unit or not....

  7. #7
    Ricekiller z28punk's Avatar
    Join Date
    Nov 2006
    Location
    Maple Grove, MN
    Age
    29
    Posts
    509

    Pewter
    2002 Camaro Z28

    i bet its the fuel guage resistor grid on the sender. if it cant read how full or empty it is they default to empty. all GM cars before 2004 are like this (except vettes, their smarter)

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    one of the first things I would do is check the ohms back at the plug coming off the tank. The 4th gens are different than older GM's that used 0-90 ohms as empty and full. The 4th gens are 33-270 ohms ( 33 being empty and 270 being full). I'll put up a pic of the wiring back there and even though it's for a 98 the 99+ used the same wire colors. Just ohm out the harness coming out of the tank and that'll tell you if it's in the tank or between the tank and gauge ( which runs through the pcm). You're looking for the purple and blk/wht wires.


  9. #9
    Junior Member
    Join Date
    Nov 2007
    Location
    Green Bay, WI
    Age
    32
    Posts
    55

    Black
    2000 SS Camaro M6

    Thanks for all the help everyone...

  10. #10
    Member ghettosled's Avatar
    Join Date
    Nov 2007
    Location
    cleveland, ohio
    Posts
    228

    pewter
    1999 camaro ss #4288

    did someone siphon out the fuel while it was in storage?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4 guage or 8
    By ss2000 in forum Stereo and Electronics
    Replies: 3
    Last Post: 04-14-2010, 12:31 PM
  2. ????gas guage????
    By 96 ta in forum General Help
    Replies: 4
    Last Post: 12-19-2007, 09:52 AM
  3. guage ?
    By djbcrazy7 in forum Stereo and Electronics
    Replies: 2
    Last Post: 09-13-2007, 05:46 PM
  4. guage pod
    By camarostripes96 in forum Parts Wanted / Trade
    Replies: 4
    Last Post: 08-29-2006, 06:39 PM
  5. Triple guage pillar and cobalt guage for sale
    By mikewood21 in forum Parts For Sale / Trade
    Replies: 11
    Last Post: 06-20-2006, 04:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •