Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24

broke my 160 t stat

This is a discussion on broke my 160 t stat within the General Help forums, part of the LSx Technical Help Section category; Originally Posted by third_shift|studios Really? both necks were identical. I have an 00 and replaced it's water pump with an ...

  1. #21
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by third_shift|studios View Post
    Really? both necks were identical. I have an 00 and replaced it's water pump with an 02's. All i did was compressed the spring with my palm and twisted

    ^^ This is correct, press and twist and it comes right out. I took my old one apart just to check it out. Did you do some cooking last night after the wife left?

  2. #22
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    Quote Originally Posted by pajeff02 View Post
    ^^ This is correct, press and twist and it comes right out. I took my old one apart just to check it out. Did you do some cooking last night after the wife left?
    was too busy cleaning the phoenix/mowing lawn/packing for a trip/eating dinner

  3. #23
    Member Rob Mellinger's Avatar
    Join Date
    May 2008
    Location
    Roanoke, VA
    Posts
    112

    White
    1998 Trans Am m6

    Quote Originally Posted by third_shift|studios View Post
    HIGHLY NOT RECOMMENDED! Swaping the innards made the parts totally defective. The tstat would not open. In trying to switch back to the stock innards, those were rendered useless so i had to buy a whole new tstat.
    I broke my new one too, swapped innards, works good. Maybe I got lucky? Been like that over a year.

  4. #24
    Junior Member metalmechanic's Avatar
    Join Date
    Jun 2008
    Location
    new iberia la.
    Posts
    50

    NBM
    2002 Firehawk T/A

    i had the same problem, i was told that the water pump must have been upgraded a some point

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: 160 degree stat.
    By Black WS-6 in forum Firebird / WS6
    Replies: 11
    Last Post: 07-18-2011, 07:10 PM
  2. T-stat
    By croslod in forum General Help
    Replies: 12
    Last Post: 12-06-2009, 02:11 PM
  3. 160 stat
    By 01tao6gto in forum GTO
    Replies: 2
    Last Post: 09-19-2007, 10:51 PM
  4. 160 Degree T-Stat?
    By GraigZ28 in forum External Engine
    Replies: 6
    Last Post: 03-15-2007, 02:42 PM
  5. 160 deg Stat!
    By tt69camaro in forum General Help
    Replies: 1
    Last Post: 05-31-2006, 11:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •