Results 1 to 4 of 4

Braking issue

This is a discussion on Braking issue within the General Help forums, part of the LSx Technical Help Section category; So I HAve a 99 ss I am having a little braking issue. if I am going 100 plus and ...

  1. #1
    Member cancam99ss's Avatar
    Join Date
    Apr 2010
    Location
    Miami
    Posts
    540

    Navy Blue
    Chevrolet Camaro SS

    Braking issue

    So I HAve a 99 ss I am having a little braking issue. if I am going 100 plus and I hit the brake nthe peddle goes down a little and then it finally gets the peddle hard. In other words the car brakes fine except when I need to suddenly breAk it like goes like if I had no brakes.... The discs and pads have less thN 10000 miles on them any ideas guys! Btw I have ebc dimpled and slotted rotors with ebb green stuff pads

  2. #2
    おれわCamaroがいじん! chaosinfinite's Avatar
    Join Date
    Apr 2007
    Location
    Washington D.C.
    Age
    31
    Posts
    198

    Black
    1998 Chevrolet Camaro SS

    I would consider checking your rotors and pads. EBC greenstuff are more of an economy pad for them, so I am not sure how well they hold up with heavy breaking like that. I personally had the "red-stuff" pads and they were champs. On the other hand, I have never heard anything good about EBC rotors at all. Check to see if your pads are still in good condition, and also check to see if your brake fluid is full. When was the last time the brake fluid was flushed?

  3. #3
    Junior Member hugh jwanger's Avatar
    Join Date
    Oct 2009
    Location
    U.K
    Posts
    28

    WHITE
    2000 SS CAMARO

    Thumbs up

    yeah, ebc reds are what u need, and i would ad braided hoses and change your fluid.

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by cancam99ss View Post
    I hit the brake nthe peddle goes down a little and then it finally gets the peddle hard. In other words the car brakes fine except when I need to suddenly breAk it like goes like if I had no brakes.
    also kinda sounds like the symptoms of a bad master cylinder

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Braking.....
    By one_sick_ss in forum General Help
    Replies: 9
    Last Post: 11-07-2012, 06:40 PM
  2. Braking issue
    By cancam99ss in forum General Help
    Replies: 6
    Last Post: 10-30-2010, 05:47 PM
  3. Braking Issue
    By weist in forum General Help
    Replies: 11
    Last Post: 11-25-2009, 03:54 PM
  4. braking problem
    By easytoremember in forum General Help
    Replies: 2
    Last Post: 10-01-2007, 07:54 AM
  5. Braking systems
    By trainingdragon in forum Suspension and Handling
    Replies: 2
    Last Post: 02-26-2006, 09:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •