Page 1 of 2 12 LastLast
Results 1 to 20 of 37

brake lights don't work

This is a discussion on brake lights don't work within the General Help forums, part of the LSx Technical Help Section category; Has this happened to anybody here? Also my turn signals dont work either. Help!!!!...

  1. #1
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    brake lights don't work

    Has this happened to anybody here? Also my turn signals dont work either. Help!!!!

  2. #2
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Youve got a bulb out somewhere...

  3. #3
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    I dont think so, that would be true for turn signals. But I have had problems with the turn signals since day one

  4. #4
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Check your sockets.. mine went bad after water ate them alive. A bulb out caused my brake lights to not function and my turn signals not to work...

  5. #5
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    ok so now they work some times and sometimes they dont wtf, do i have a short?

  6. #6
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    I say you have bad socket or poor ground

  7. #7
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    what gauges aren't workin???

  8. #8
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    I think its a ground also, all the gauges work fine

  9. #9
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    sorry wrong thread...

    +1 for teh ground...

  10. #10
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    anybody know where the ground located on the car

  11. #11
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    anybody know where the ground located on the car

  12. #12
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    Also the third brake light on the wing works but the others dont.

  13. #13
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    ground should be in the left side, behind tailight, or inside quarter panel near light plug...
    this is a diff harness than the wing...

  14. #14
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    cool thanks man, Ima check it out when i get home.

  15. #15
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    np. let us know what you find...

  16. #16
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    Well the ground looked fine but I ahead and cleaned it up with some paper and tightened it up. They work now!! I hope they stay working.

  17. #17
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Doomtacular

  18. #18
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    they dont work anymore, but they work sometimes. Think it could be the brake switch

  19. #19
    Junior Member
    Join Date
    Feb 2008
    Location
    friendswood,tx
    Age
    36
    Posts
    17

    maroon
    2000 chevy tahoe

    mulifunction switch most likely gm is bad about those

  20. #20
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    if it was the switch... the wing light wouldn't work either...

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 12-16-2014, 03:35 AM
  2. Help: no brake lights
    By Spoiledoneinar in forum Firebird / WS6
    Replies: 13
    Last Post: 05-25-2012, 06:12 PM
  3. Help: Brake lights wont work
    By mrpontiac80 in forum General Help
    Replies: 18
    Last Post: 05-11-2011, 05:48 PM
  4. Turn signals and brake lights don't quite work..HELP!!
    By Kaution vBi in forum General Help
    Replies: 1
    Last Post: 08-05-2007, 10:45 AM
  5. Brake Lights wont work
    By blackTA6585 in forum General Help
    Replies: 6
    Last Post: 02-20-2006, 06:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •