Results 1 to 7 of 7

Both cigarette outlets are dead, why?

This is a discussion on Both cigarette outlets are dead, why? within the General Help forums, part of the LSx Technical Help Section category; I have checked all fuses in both fuse boxes in the engine bay,,, all are good. Why would both cigarette ...

  1. #1
    Member
    Join Date
    Aug 2005
    Location
    Newport, Mi.
    Posts
    116

    red
    1999 Camaro SS

    Both cigarette outlets are dead, why?

    I have checked all fuses in both fuse boxes in the engine bay,,, all are good. Why would both cigarette (power points) be dead all of a sudden? Both had power on one drive, next drive they are dead. The car is a 1999 Camaro SS.

  2. #2
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    69
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Have you checked the fuses in the dash??

  3. #3
    Junior Member 346DubS6's Avatar
    Join Date
    Oct 2007
    Location
    Nor-Cal Bay Area
    Posts
    39

    White
    2001 WS6

    I have the same problem. I too want to know how to fix this..maybe carry an extra lighter hmm

  4. #4
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by rbob93 View Post
    Have you checked the fuses in the dash??
    that was my first guess, there is one for it i'm pretty sure.

  5. #5
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Yes there is one for it. The ones under the hood are the primary systems and high draw circuits. The lighter outlets are fused or on a breaker, What can happen is that as they are used small shavings can short our on the hot and ground terminals. blow them out or stick a magnet in them, power odd of course. See if that fixes it.

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Check the CIG/ACCY fuse inside the car.

  7. #7
    Member
    Join Date
    Aug 2005
    Location
    Newport, Mi.
    Posts
    116

    red
    1999 Camaro SS

    Thank you. I have not checked the cabin fuses, forgot they were even there.

    I think that my radar detector shorted out some how. The detector works in other cars. So it must be the fuse in the cabin is blown. I will need to find out why the detector shorted out the fuse.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. LS1 heater outlets
    By carjunkie in forum General Help
    Replies: 2
    Last Post: 08-13-2010, 06:21 AM
  2. electronic cigarette
    By doberman 152 in forum Almost Anything Goes
    Replies: 40
    Last Post: 04-26-2009, 07:42 PM
  3. What the heck is going on with my outlets...?
    By Firebird Phoenix in forum Almost Anything Goes
    Replies: 12
    Last Post: 01-07-2009, 06:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •